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Product Concept

Paragon ExtFS for Windows is a file system driver that can offer full read/write access to Linux-native Ext2 / Ext3 /
Ext4 volumes under Microsoft Windows. With our driver onboard, you can plug in ExtFS storages to your PC to get
access to their contents for reading, copying, or modification.

Paragon ExtFS for Windows doesn’t work in the kernel mode, but uses the Dokan library, which is similar to FUSE
(Linux user mode file system), but for Windows OS. In short, Dokan enables to easily create a fully functional file
system driver in a userspace program. For more information, please visit:

http://dokan-dev.github.io/.

Key Features
e Provides fast and transparent read/write access to Linux Ext2 / Ext3 / Ext4 under Windows
e Gets ready to work in a couple of minutes
e Supports the latest Windows 10
e Managed through Windows system tray
e Managed from Windows CMD
e Supports Linux LVM (Logical Volume Manager) disks
e Includes ‘Runs at startup’ and ‘Automount’ features

e Safe eject ready

Key Use Cases

e Import/Export data from/to ExtFS volumes. Let’s assume that a hard drive has been taken out from NAS
storage based on Linux and you need to copy files to or from this disk under Windows OS. Just install our
driver, connect this disk via eSATA connector or USB-to-SATA adapter to your PC and here you go — all
files on Linux-native volumes are available to work with under Windows.

e Open documents and multimedia directly from ExtFS volumes. If you want to watch movies or open
large documents contained on a Linux-native volume from your PC, simply install our driver, connect this
disk directly to your PC and enjoy the show.

Getting Started

In this chapter you will find all the information necessary to get the product ready to use.

System Requirements
e Windows 7
e Windows 8
e Windows 8.1
e  Windows 10
e Windows Server 2008
e Windows Server 2012 R1/R2

Installation

1. Click on the supplied setup file to initiate the installation.
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http://dokan-dev.github.io/

2. Click Continue on the Welcome page.

3. Inorder to continue the installation you are to accept all conditions stated in Paragon’s license
agreement. You can also print out the agreement by using the appropriate button.

End.user License Agreement for Paragon Software Products

m|>

This End-User License Agreement (‘EULA') is a legally valid contract
between the end user of the software and Paragon Software GmbH,
Heinrich-von-Stephan-Strae 5c¢, D-79100 Freiburg (hereinafter referred
to as ‘Paragon’). Please read this Agreement thoroughly before
acquiring the software. Upon acquisition of the software, the following
provisions will be deemed to have been agreed to with binding effect.

1. Copyright
This software product, including any handbooks, instructions and/or v

[¥]1 accept the terms in the License Agreement

4. By default the product will be available for all users of this computer. If you'd like it to be available for the
current user account only, please choose the corresponding option.

O Install just for you (Administrator)

Paragon ExtFS for Windows will be installed in a per-user folder and be available
just for your user account. You do not need local Administrator privileges.

@® Install for all users of this machine

Paragon ExtFS for Windows will be installed in a per-machine folder by default and
be available for all users. You can change the default installation folder. You must
have local Administrator privileges.

5. If necessary manually edit the installation path or click Change... to browse for the required location.

Install Paragon ExtFS for Windows to:

IC:\Program Files (x86)\Paragon Software\ExtFS for Windows\

6. By default the installation folder will be added to the PATH environment variable to let you manage the
driver from the command line without typing the whole path to its executable file. Unmark the checkbox
if you don’t need it.

Add to the environment variable PATH the Paragon ExtFS for Windows installation
directory

7. Click Install to roll out the installation.

Flease wait while the Setup Wizard installs Paragon ExtFs for Windows.

Status: Installing new services

8. Finally you will be prompted to enter a serial number and thus activate the product. You can find it in the
product box or obtain from your reseller. If you don’t have a serial number yet, skip this action by marking
the corresponding option. For more details, please consult the Product Activation chapter.

Serial Number: |

D Continue without activation
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Product Activation

ExtFS for Windows is a commercially distributed product, which is however can be used with no limitations

completely for free during a 10-day trial period. After that you won’t be able to use it until activated over the
Internet.

Start Trial

If you haven'’t activated the product during the installation, you can start a 10-day trial period through the
program interface.

1. Double click the product icon on the Windows desktop.
2. Select Help > Activate the product.
3. Click on Start Trial.

= Paragon ExtFS for Windows | CET |
File Help
Volume label Mount point Size
= @ disk3
(U)LINUXVOLUME 40.00 Gb

SOFTWARE GROUP

?Sa ParaGgcon

Please activate the software with your Serial Number or start 10-days trial period

[ Buy Full Version... | | Start Trial |
o
g

4. Once done, all found ExtFS volumes will be automatically mounted (assigned drive letters).

= Paragon ExtFS for Windows | = | & [IEH

File Help
Volume label Mount point Size
# (RW)LINUXVOLUME G\ 40.00 Gb

Tree list was updated

Online Activation

If you haven’t activated the product during the installation, you can purchase and unlock it for unlimited use at
any moment through the program interface. The recommended procedure requires an active Internet connection

and minimal participation from your part. However, if you don’t have the Internet on the target computer, you
can try an offline option.

There are two ways of activating the product over the Internet: with login to MyParagon Customer Portal and
without it. We highly recommend you to use the first option to let us offer you personal discounts in the future.
Besides, you will be able to issue support tickets directly from the product.
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1. First you should purchase the product. The easiest way is to use a direct link:

Double click the product icon on the Windows desktop.
Select Help > Activate the product;

- Click on Buy Full Version...

Paragon ExtFS for Windows

- | O X
File Help
Volume label Mount point Size
= @@ disk3
(U)LINUXVOLUME 40.00 Gb

SGParaGon

SOFTWARE GROUP

Please activate the software with your Serial Number or start 10-days trial period

l Buy Full Version... I Start Trial I

2. By this moment you should have your own serial number. Click on Activate.

Activating with login

3. Inthe opened dialog enter an email and password of your Paragon’s account, then click Sign in
= Paragon ExtFS for Windows =1 ==
File Help
Volume label Mount point Size
= & disk3

(U)LINUXVOLUME 40.00 Gb
[x ]
Login to account -
Email: |jimbubb|estone@gmail.com |
Password: | eecscsscsssssee |
I Activate Offline ] I Restore Password I

Plez I Cancel ” Activate Without Login l | Sign in ’ piod
,Ey Full Version... | | Start Trial | Activate

If you have purchased the product online as described in the first step, then your serial number will be
pasted automatically. If having to do with a box version of the product, enter your serial number, then
click Activate. This info will be sent to our activation server to complete the procedure.

Activate your serial -

Serial:

l 683T4U-5PVJAR-528D4)-ACTTI2-3N81KS |

GUID:

| 00252-60020-02943-AA683 ]

GUID (globally unique identifier) - is a unique reference number used as

an identifier in computer software. Paragon license will be linked to
your GUID.

5. If asuccess, you’ll get a corresponding notification.
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Activating without login
In the opened dialog click Activate Without Login.

3.
= Paragon ExtFS for Windows | = | =) | z |
L x|
Size
DO Gb

| Restore Password |

| Activate Offline |

Sign in |

Cancel || Activate Without Login |

[[] Don't show this dialog again

Tree list was updated
4. Enter your serial number, then click Activate. This info will be sent to our activation server to complete

the procedure.

Serial: | 683T4U-5PVJAR-528D4)-ACTTI2-3N81KS

GUID: | 00252-60020-02948-AA683

GUID (globally unique identifier) - is a unique reference number used as
an identifier in computer software. Paragon license will be linked to

your GUID.

If a success, you’ll get a corresponding notification.

5.
Offline Activation
1. If having problems with the Internet or specifically configured Firewall at login to your Paragon’s account

on the target computer, try an offline option.
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[

Size

Email: I 00 Gb

Password: I |

[ Activate Offline | [ Restore Password |

I Cancel " Activate Without Login | ‘ Sign in I

[[]Don't show this dialog again

Tree list was updated

2. Write down your GUID and the provided link somewhere.

GUID: [ 00252-60020-02948-AA6S3 |

Go to https://my.paragon-software.com/activate, create a license file to bind your
serial number and device identifier (GUID), then import the created license file with
the «Select License File» button below.

GUID (globally unique identifier) - is a unique reference number used as an identifier
in computer software. Paragon license will be linked to your GUID.

socmeri

3. Use the saved link on any computer with the Internet to visit the company’s website to sign in to your
Paragon’s account.

MyParagon Customer Portal

Sign in
or create an account

jimbubhlestone@gmail.com

OR SIGH N WITH

f Facebook

4. Enter your serial number and GUID in the corresponding fields, then click Export license file.
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Offline activation

If you've arrived on this page, chances are you're having a problem activating your copy of a
Paragon Software product online.

To resolve this issue, we offer an offline activation procedure, which takes just three simple
steps:

1. Create a special license file, which binds the serial number of your product together with a
unique identifier for your system (GUID). You can locate the GUID of your computer in the
software’s offline activation dialog.

2. Export the license file to your computer.

3. Import the license file from your system to the Paragon product installed on the device with
the license-bound GUID.

For steps 1 and 2, please enter your serial number and device GUID in the form below to
generate the license file. Next, click «Export license file».

683T4U-5PVJAR-S28D4J-ACTTI2-3N81KS X

00252-600020-02948-AA683

Export license file

[ Send email ]

When finished, you'll need to switch back to the Paragon Software product and import the
created license file.

If you still have questions or issues activating your software, please contact our Support Team
via MyParagon > Support > New Support Request.

5. If the provided data is valid, you should get the “LicenseSet.xml” file. Copy it to the target computer, then
use the Select License File option for the import.

6. If a success, you’'ll get a corresponding notification.

Working with the Driver

After the product has been installed and activated, Windows will automatically mount (assign drive letters to) all
found ExtFS volumes, which you can see in the main window of the driver by clicking its desktop icon,
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= Paragon ExtFS for Windows - O b4

File Help
Velume label Mount peint Size
= = diskd
& (RWJHDDEXT2 F:\ 153.70 Gb
& (RWJHDDEXT3 G 153.70 Gb
& (RWJHDDEXT4 Hey 158.36 Gb
= &= lvm
& (RWvelumel I 15.99 Gb

Mount

Tree list was updated

or through the Windows system tray.

Yo | =

by

Custemize...

BB goms

ExtFS for Windows

=2 | disk3

L] (RW)LINUXWVOLUME 40.00 Gb
Exit

Now you can carry out any operation on an ExtFS volume as if it's Windows-native:
e Transfer data,
e Modify data,

e Delete data, or whatever you feel like doing.

o ExtFS volumes won’t be mounted until you activate either the full or trial version. For more
details, please consult the Product Activation chapter.

Configuring the Driver
Paragon ExtFS for Windows is very flexible and can be easily set up either with the help of a graphical interface or
from the command line.
Setting up through Graphical Interface
1. Double click the product icon on the Windows desktop.
2. Select File > Settings.

3. By default all found ExtFS volumes are automatically mounted in read/write mode at the system startup.
Furthermore, all actions accomplished by the driver are logged. If you'd like to change it, mark/unmark
checkboxes opposite the required options.
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= Paragon ExtFS for Windows =

Volume label “ Mount point
= & disk3
# (RW)LINUXVOLUME G:\
s Settings

[#] Implement auto mount
[1Read only

[#] Turn on logging
‘ Ok i] Cancel

Setting up from Command Prompt

e Installing the driver (quite installation with a serial number).

icrosoft Windows [Uersion 6.3.96881
(c> 2813 Microsoft Corporation. All rights reserved.

sUserssAdministratorrmsiexec /i InstallParagonExtFSforWindows.msi SERIALNUMEBER

=IO MO IO —HHKKHK Sguite

e Configuring the driver.

icrosoft Windows [Uersion 6.3.96881
(c> 2813 Microsoft Corporation. All rights reserved.

NUserssAdministratordextmounter

EET

y e s/mount [/ro — read onlyl [disk#t.lvm#t] [volume#] [mount point] — mount wvo

ume{s
sumount [disk#,lem#t] [mount point] — wunmount volumeds>
slist — show ext tree( disk-svolume >
sugm [uid valuel [gid valuel I[mode valuel

NUserssAdministratord

As an example, you can see output of the list command:

icrosoft Windows [Uersion 6.3.96H801
(c> 2813 Microsoft Corporation. All rights reserved.

sWindowsssystemd2>"C:sProgram Files {(x86>“Paragon SoftwaresParagon ExtFS for U
indowshextmounter.exe" /list
[Dizk@

Volumel 3%.99 Gh C HNTFS-/exFAT

Uolumel @.28 Gh EF] system partition
Uolume2 465.57 Gh E ExtFS

UWindowsssystem3d2>

Updating the Driver

1. Double click the product icon on the Windows desktop.
2. Select Help > Check for updates.

3. If a new version of the driver has been found, you will be prompted to install it.
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= Paragon ExtFS for Windows ==
File Help
Volume label = Mount point Size
= & disk3
& (RW)LINUXVOLUME G:\ 40.00 Gb

You're up to date!

Paragon ExtFS for Windows 4.0.151 is currently the
newest version available.

Close

Submitting Support Request

In case of having difficulties with handling the product you can address our support engineers for assistance. To
help you solve your problem with minimal time, our engineers need operation logs and your brief description.

To get the logs file, please do the following:
1. Double click the product icon on the Windows desktop.
2. Select Help > Show log.

3. Get in touch with our support engineers and send them the logs.

File Home Share View V. 0
P l . <« Program Files (x86) » Paragon Software » ExtFSfor Windows » v ¢ I I Search ExtFS for Windows y el I
,‘:( Eavontes A | Name : Date modified Type Size
B Desktop |, Dokan 6/21/2016 1:28 AM  File folder
& Downloads .. Updater 6/21/2016 1:28 AM  File folder
%2 Recent places %, dokan.dll /10/2016 11:46 AM  Application extens... 403 KB
| || extfs_for_win 4.0.151 6/21/2016 246 AM  Text Document 68 KB
1% This PC = [ etmounter 6/10/2016 11:51 AM  Application 227KB
= Desktop 7] extservice 6/10/2016 11:50 AM  Application 1,900 KB
| Documents m OnlineActivator 6/10/2016 11:11 AM  Application 4,793 KB
& Downloads = Paragon ExtFS for Windows 6/10/2016 11:51 AM  Application 3,642 KB
& Music
=/ Pictures
B Videos ||
i, Local Disk (C:)
ca Data Volume (E:)
ca Data Volume ) v)
8items  1item selected 67.7 KB

o Log files do not contain any confidential information on the operating system settings or
the user documents.
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