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1 Introduction  
Sooner or later any PC user faces the problem of modifying the hard disk structure. One day you realize that 
your hard drive cannot meet your requirements any more. Either its capacity is insufficient and it is time to 
think about a little upgrade, or you are to carry out some partitioning operations. Whatever the problem is, it 
requires solution. 
 
Our program is a fast, convenient and reliable solution of disk copying, upgrading and configuring needs. It 
provides a wide-range functionality in the field of managing disk layout structures. The key features of the 
program are listed in the special chapter. 
 
Setting up any operation is accomplished by using practical wizards. Each step of the wizard includes in-
depth information in order to allow the user to make the right choice. Graphical representations of the data 
help the user to gain a better understanding. 
 
In this manual you will find the answers to many of the technical questions which might arise while using 
the program. 

2 Key Features  
Let us list some of the key features:  
 

� User friendly interface. Easily understood icons accompany all functions of the program. 
� Previewing the resulting layout of hard disks before actually executing operations (so-called virtual 

operations). 
� Copy Partition/Hard Disk Wizards that enable to successfully transfer all on-disk information 

including standard bootstrap code and other system service structures, thus maintaining the operating 
system’s working capability, and that even beginners may understand. 

� Basic functions for initializing, partitioning and formatting hard disks. Instead of the standard 
Windows disk tools, the program supports all file systems. 

� Recovering of any accidentally deleted partition by using the Undelete Partitions Wizard. 
� Schedule the operation. The user can set a convenient time for the program to perform the operation 

automatically. 
� Shutdown After Apply function enables to set the computer to automatically switch off on the 

successful accomplishment of any scheduled operation. 
� Build external recovery media that help the user to restore the system even when the current 

operating system cannot boot anymore. 

3 Drive Copy Editions 
The product is being released in several editions, Personal and Professional, which vary in price and 
provided functionality. Additional to the features supported by the Personal version, the Professional 
version of the program provides the following advanced functionality: 

 
� Windows Server support. It can be installed on and run under Windows 2000/2003/2008 Server 

Family, providing the ability to work in Terminal Sessions. 
� Possibility to send notifications by e-mail on the carried out operations. 

 
Supported Operating Systems 
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OS Personal Professional 

Windows Me No No 
Windows NT No No 
Windows NT Server Family No No 
Windows 2000 Professional Yes Yes 
Windows XP Home Edition Yes Yes 
Windows XP Professional Yes Yes 
Windows XP Professional 64-bit Yes Yes 
Windows 2000 Server Family No Yes 
Windows Storage Server 2003  No Yes 
Windows Server 2003 Web No Yes 
Windows Server 2003 Standard/ 64-bit No Yes 
Windows Server 2003 Enterprise/ 64-bit No Yes 
Windows Server 2003 Enterprise Itanium No No 
Windows Server 2003 Datacenter/ 64-bit No Yes 
Windows Server 2003 Datacenter Itanium No No 
Windows Small Business Server 2003 Standard/ Premium No Yes 
Windows Server 2008 Web/ 64-bit No Yes 
Windows Server 2008 Standard/ 64-bit No Yes 
Windows Server 2008 Enterprise/ 64-bit No Yes 
Windows Server 2008 Datacenter/ 64-bit No Yes 
Windows Server 2008 for IA64 No No 
Windows 2008 HPC Server Edition No Yes 
Windows 2008 Essential Business Server Edition No Yes 
Windows Small Business Server 2008 64-bit No Yes 
Windows Vista/ 64-bit Yes Yes 

 

 
Please take into consideration the mentioned above peculiarities of the certain versions when 
working with the program. 

4 Installation  
This chapter provides information which is needed to perform the correct installation of the program, and in 
addition, checks if the current installation is working correctly.  

4.1 Package Contents  
The installation package includes the following components:  

� Launcher (with an embedded HTML browser)  
� Partition Management 
� Hard Disk Management 
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� Scheduler with Task Editor 
� Extra Functionality 
� Recovery Media Builder 

4.2 Minimum System Requirements  
To use the program on a computer satisfactorily, ensure that it meets the following minimum system 
requirements:  

� Operating systems: Windows 2000/XP/Vista/Server 2003/2008 and XP SP2/Vista/Server2003/2008 
64-bit  

� Internet Explorer 5.0 or higher  
� Intel Pentium CPU or its equivalent, with 300 MHz processor clock speed  
� 128 MB of RAM  
� Hard disk drive with 40 MB of available space  
� SVGA video adapter and monitor  
� Mouse  

4.3 Installation Procedure 
The installation process consists of the following steps: 
 
1. Run Setup Application 
From the folder, where the setup files are kept, run the SETUP.EXE file. This application will guide the user 
through the process of the program installation. The setup utility is compiled with the InstallShield SDK, 
hence it contains the standard user interface and set of installation steps. 
 

 
In case there is some previous version of the program installed on the computer, the program 
will offer the user to uninstall it first. 

 
2. Starting Setup 
The Welcome page informs that the application is being installed. Click the Next button to continue. 
 
3. Confirm License Agreement 
The License Agreement page displays the Paragon License Agreement. Read the agreement and then click 
the Yes button to accept. If the user does not agree with any conditions stated there, the installation process 
will be interrupted. 
 
4. Select an Installation Folder 
The Destination Location page allows the user to choose the folder where the program will be installed. By 
default, the installation folder will be created as: 
 
C:\Program Files\Paragon Software\Paragon Drive Copy. To select another folder, click the Browse 
button. 
 
After you have selected the required folder, click the Next button to continue. 
 

 
Do not install the program on network drives. Do not use Terminal Server sessions to install 
and run the program. In both cases, the program functionality will be limited 

 
5. Select a Program Group 
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The Program Folder page enables the user to select the application's program group for the Start Menu. By 
default, it will be the program group: 
 
Start > Programs > Paragon Drive Copy. 
 
Click the Next button to continue. 
 
6. Verify Setup Settings 
 
The Start Copying page allows the user to verify settings, which have already been made and correct them if 
necessary. Press the Back button to return to the previous page and modify the installation settings. Click the 
Next button to complete the installation process. 
 
7. Copying Files 
 
The Setup Status page shows the overall progress of the installation. Click the Cancel button to abort the 
setup. 
 
8. Finishing the Installation 
 
The Final page reports the end of the setup process. 
 

 

To accomplish online backup/copy of locked partitions/hard disks the program uses a kernel 
mode hotcore driver, thus the system reboot is required to complete the installation 
procedure. 

5 Basic Concepts  
This chapter explains terms and ideas that show how the program works. To understand these helps to obtain 
a general notion of the operation performance and makes it easier for the user to operate the program. 

5.1 Copy Operations 
Hard drive duplication nowadays is becoming highly popular among PC users. That is due to some definite 
advantages it can offer. First of all, many people clone hard disks just to back up data for security reasons. 
The present day copy utilities enable to successfully transfer all on-disk information including standard 
bootstrap code and other system service structures, thus maintaining the operating system’s working 
capability. In case of a system malfunction, the user can get the system back on track in minutes. No 
additional configuration is required, what is very convenient. 
 
The second possible application is the upgrade of a hard disk to a new one. The capacity of a modern hard 
drive doubles every two years, thus opening up new possibilities for software developers. As a result 
programs become more complicated and require considerable amount of free space. One day the user 
realizes that there is no more free space left on the hard disk and the only way out is to upgrade. Usually that 
means that besides purchasing a new hard disk, the user is to face a large re-installation procedure spanning 
several days of tedious work. But all of this can be avoided just by copying the contents of the old hard disk 
to a new one proportionally resizing the partitions. 
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5.2 Drive Partitioning 
As you probably know a hard drive is to be split into one or more partitions, since it cannot hold data until it 
is carved up and space is set aside for the operating system. Until recently most PCs used to have just one 
partition, which filled the entire hard disk and contained the OS. The situation has changed however, thanks 
to new cost-effective high capacity hard drives, thus opening up numerous possibilities for PC users, such as 
editing video, archiving music, backing up CD images, etc. Huge increase in space is great, but it poses a 
number of problems, most important of which are effective data organization and speed. 
 
Large drives are always going to take longer to search than smaller volumes, and an operating system is 
going to have its work cut out both finding and organizing files. It is for this reason that many people decide 
to invest in multiple hard drives, but there is an easy solution – drive partitioning. Partitioning lets you 
divide a single physical drive into a number of logical drives, each of which servers as a container with its 
own drive letter and volume label, thus enabling the operating system to process data more efficiently. 
Besides partitioning makes it possible to organize data so that it is easy to find and manage. You can set 
aside, for instance, 40 GB of a 160 GB hard drive for the OS, 70 GB for storing video and another 50 GB for 
your favorite music collections to provide transparent data storage. 
 
It is also worth mentioning to that with a hard drive properly partitioned, such routine operations as files de-
fragmentation or consistency check will not be that annoying and time-consuming any more. 
 
By detaching the OS from the rest of the data you can tackle one more crucial issue – in case of a system 
malfunction, you can get the system back on track in minutes by recovering it from a backup image located 
on the other partition of the hard drive. 
 
But that is not all drive partitioning may be used for. If you are willing to play games in Windows while 
browsing the Internet in Linux, 100-percent sure that no virus will attack your PC, drive partitioning is a 
necessity. In order to run several OSs on a single hard drive you are to create a corresponding number of 
partitions to effectively delineate the boundaries of each OS. 
 
All of the above-mentioned partitioning applications are implemented in the program. And all the necessary 
actions are performed by using the system of convenient wizards. This means that the user simply has to 
follow easy step-by-step instructions to make the appropriate settings.  

5.3 64-bit Support 
The bulk of software today is written for a 32-bit processor. It can meet the requirements of almost any end 
user. However that is not the case when dealing with servers processing large amounts of data with complex 
calculations of very large numbers. That is where 64-bit architecture comes into play.  
 
It can boast improved scalability for business applications that enables to support more customer databases 
and more simultaneous users on each server. Besides a 64-bit kernel can access more system resources, such 
as memory allocation per user. A 64-bit processor can handle over 4 billion times more memory addresses 
than a 32-bit processor. With these resources, even a very large database can be cached in memory.  
 
Although many business applications run without problems on 32-bit systems, others have grown so 
complex that they use up the 4 GB memory limitation of a 32-bit address space. With this large amount of 
data, fewer memory resources are available to meet memory needs. On a 64-bit server, most queries are able 
to perform in the buffers available to the database. 
 
Some 32-bit applications make the transition to the 64-bit environment seamlessly others do not. For 
instance, system-level utilities and programs that provide direct hardware access are likely to fail. Our 
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program offers a full-fledged support of the 64-bit architecture providing fault-tolerant work for such system 
dependent modules as Hot Processing. 

5.4 Scheduling  
The automation of the program’s operations is particularly effective when the user has to repeat a sequence 
of actions on a regular basis. For example, when a hard disk copying is made every evening so as not to lose 
valuable data, it should be possible to simplify certain routine operations. 
 
Another aspect of any automation process is that it runs automatically without the user having to be present. 
The program is able to execute operations without the user being involved. In addition, it allows an 
optimization of your computer’s work-load. This is especially important when operations require a 
considerable amount of computer resources – processor time, memory and more. A number of operations, 
which can decrease the performance, can be run during the night or whenever the computer has the least 
work-load to perform. 
 
The program has a special tool for scheduling. The user can set out a timetable for various copy operations. 
For example, some operations may be performed daily, others - weekly and so on. The scheduled operation 
starts at a specified time without interrupting the user's current activity (due to using Hot Processing 
technology). 

6 Interface Overview  
This chapter introduces the graphical interface of the program to the user. The design of the interface 
precludes any mistake being made on the part of the user. Most operations are performed through the system 
of wizards. Buttons and menus are accompanied by easy understandable icons. Nevertheless, any problems 
that might occur while managing the program can be tackled by reading this very chapter. 

6.1 General Layout  
When the user starts the program, the first component that is displayed is called the Launcher. It enables the 
user to run wizards and utilities, to specify program settings, to visualize the operating environment and the 
hard disk configuration. 

The Launcher’s window can be conditionally subdivided into several sections that differ in their purpose and 
functionality: 
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1. Main Menu  
2. Tool Bar  
3. Virtual Operations Bar  
4. Common Tasks Bar  
5. Explorer Bar  
6. Disk Map  
7. Legend Bar 
8. Status Bar  
 
Some of the panels have similar functionality with a synchronized layout. The program enables the user to 
conceal some of the panels to simplify the interface management. 
 
All panels are separated by vertical and horizontal expandable sliders, allowing the user to customize the 
screen layout. 

6.2 Main Menu  
The Main Menu provides access to the entire functionality of the program. The available functions are as 
listed below: 

MENU ITEM  FUNCTIONALITY  
Tools     
Save to Scheduler… Schedule pending operations 
Send Log Files Compress and send the log to the Paragon Support Team 
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Settings... Edit the general settings of the program  

Recovery Media Builder… Restore the system even when the current operating system cannot boot 
anymore 

Exit  Exit the program  
Changes  
Undo "the last virtual 
operation" Cancel the last virtual operation on the List of Pending Operations 

Redo "the last virtual 
operation" Cancel the last undo virtual operation on the List of Pending Operations 

View Changes… Display the List of Pending Operations 
Apply Changes Launch the real execution of virtual operations 
Discard All Changes Cancel all virtual operations on the List of Pending Operations 
Reload Disk Info  Refresh the current information about disks  
Wizards    
One Button Copy Wizard  Create a hard disk copy just by pressing one button 
Copy Hard Disk…  Create a hard disk copy  
Schedule Hard Disk 
Copy…  Schedule a hard disk copy 

Copy Partition…  Create a partition copy 
Schedule Partition Copy… Schedule a partition copy 
Undelete Partitions… Recover any of accidentally deleted partition 
Hard Disk  
Update MBR Update MBR (Master Boot Record) of the selected hard disk 
Change Primary Slots… Modify the primary partitions enumeration for the selected hard disk 
Change SID… Change SID (Security Identifier) value of any found Windows installation 
Properties… Get in-depth information on the properties of selected hard disk 
Partition  
Create Partition… Create a partition of any file system with the Create Partition dialog 
Format Partition… Format a partition of any file system Format Partition dialog 
Delete Partition… Delete a partition of any file system Delete Partition dialog 
Assign Drive Letter… Assign drive letter to the selected partition 
Remove Drive Letter… Remove drive letter for the selected partition 
Hide Partition… Make the selected partition unavailable for the operating system 
Unhide Partition… Make the selected partition available for the operating system 
Mark Partition as Active Make the selected partition bootable by default 
Mark Partition as Inactive Make the selected partition non-bootable by default 
Change Volume Label… Change volume label of the selected partition 
Change Serial Number… Change serial number of the selected partition 
Change Partition ID… Change identifier of the selected partition 
Test Surface… Test surface of the selected partition/block of free space 
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Check File System 
Integrity… Check the selected partition for possible file system errors 

Properties… Get in-depth information on the properties of selected partition 
View     

Toolbar  Manage the Tool Bar representation: show / hide standard and navigation 
buttons, text labels and large icons.  

Status Bar  Display the Status bar  
Common Tasks Bar  Display the Common tasks bar  
Disk Map Legend Display the Disk map legend 

Disk Map Location  Select whether the Disk map will be located on the top of the main window 
or at the bottom  

Help     
Help  Open the Help system  
About  Open the dialog with information about the program  
 

 
The Main Menu contents available at the moment may vary depending on the selected object.

6.3 Tool Bar  
The Toolbar provides fast access to the most frequently used operations: 

BUTTON FUNCTIONALITY  

 
Copy a hard disk 

 
Copy a partition 

 
Schedule a hard disk copy 

 
Schedule a partition copy 

 
Open the Help system  

6.4 Virtual Operations Bar  
The program supports previewing the resulting layout of hard disks before actually executing operations (so-
called virtual mode of execution). In fact, when the virtual mode is enabled, the program does not 
accomplish operations immediately, but places them on the List of Pending Operations for later 
accomplishment. 
 
The Virtual Operations Bar enables to manage pending operations. 
 
BUTTON FUNCTIONALITY  
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Cancel the last virtual operation on the List of 
Pending Operations 

 
Cancel the last undo virtual operation on the 
List of Pending Operations 

 Display the List of Pending Operations 

 Launch the real execution of virtual operations 

 
Cancel all virtual operations on the List of 
Pending Operations 

 

 

Virtual mode is an effective way of protection from any troubles, since no operations will be 
executed until clicking the Apply button for confirmation, thus giving a second chance to 
weigh all pros and cons of this or that particular operation. The program politely reminds the 
user that there are unsaved changes by showing the following window: 

 
 
In the process of making virtual operations, you might notice at some moment, that drive 
letters stop displaying on the Disk Map. Please don’t worry, that is just a program issue and 
everything will be ok after applying. 

6.5 Common Tasks Bar  
The Common Tasks Bar is located on the left side of the main window. It is intended for easy access to the 
program's wizards that provide all the functionality needed to manage copy operations. 

The bar contains two tabs named Copy Tasks and News and Documentation. Each of these contains a 
separate button bar which can be folded by clicking it. 

Copy Tasks    
Starting the One Button Copy Wizard. The One Button Copy Wizard assists 
the user with cloning of hard disks just by pressing one button. 

Starting the Copy Hard Disk Wizard that helps to make an exact copy of a 
hard disk. 

Starting the Schedule Hard Disk Copy Wizard with the preset scheduling 
option. 

Starting the Copy Partition Wizard that helps to make an exact copy of a 
partition. 
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Starting the Schedule Partition Copy Wizard with the preset scheduling 
option. 

News and Documentation     
Opening the page which contains information about the program. This page 
will be displayed in the Explorer bar. 

Launching the Help system.  

6.6 Disk Map  
The Disk Map is displayed in the Explorer bar when the Disk View tab is selected. It is located either at the 
top or at the bottom of the window, depending on the state of the Disk Map Location option (Main menu: 
View > Disk Map Location). The user can change the current location of the map with this option. 
 
As the name infers, the Disk Map displays the layout of physical and logical disks. Physical disks are 
represented with rectangle bars that contain small-sized bars. These small-sized bars represent logical disks. 
Their color depends on the file system of the appropriate partition. 
 

 
 
Large-sized bars display the following information about physical disks: 

� Manufacturer, 
� Model. 

 
Small-sized bars display the following information about logical disks: 

� Serial number, 
� Drive letter, 
� Total size, 
� File system. 

 
Furthermore, it is possible to estimate the used disk space by looking at the size of the bar’s shaded area. 
 
Disk Map is synchronized with the Explorer bar. When the user selects a disk on the Disk Map the Explorer 
bar displays detailed information of the selected disk. 
 

 

The user can click a large-sized bar to display information about the appropriate physical 
disk in the Explorer bar. A click on a small-sized bar will lead to displaying information 
about the appropriate logical disk. 

6.7 Explorer Bar 
The Explorer Bar is located in the center of the main window which emphasizes its importance. The bar 
displays reference information including: 
 

� User Manual, 
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� Information about the program consisting of the product's name, the version of the program and a list 

of helpful links, 
� Detailed information about disks selected on the Disk Map, 
� List of scheduled operations. 

 
According to these categories the Explorer bar has three tabs: 
 

� Disk View, which allows the user to view detailed information about any of the disks. 
� Scheduled Tasks, which gives the user the possibility of browsing and editing scheduled operations. 
� Help System, which contains the User Manual and information about the program. 

 
The user is able to access the desired information by clicking on the appropriate tab. 
 
The Explorer Bar is a fully-functional embedded HTML browser, which enables the user to address, for 
example, our company's website to look through important technical notes or download the latest updates 
without having to close the program. The Help System of the program is HTML-oriented. The user can read 
the user manual and follow external links from to get additional information. 
 

 
 
To easily navigate through browsed pages, the program provides the following functionality: 
 
BUTTON FUNCTIONALITY  

 Return to the previously browsed page  

 Open the next browsed page  

 Stop loading the current page  

 Refresh the contents of the current page  
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The Legend Bar explains the color scheme used for disk and partition presentation. The user can hide (or 
show) the bar with the appropriate Main menu item: View > Disk Map Legend. When it is activated it can be 
found at the bottom of the Explorer bar.  
 
The program distinguishes between the following types of known file systems: 
 
   - FAT16/32,  
   - NTFS, 
   - Linux Ext2/3,  
   - Linux ReiserFS. 

6.9 Status Bar  
This is the bottom part of the main window. The status bar displays menu hints, for each item the cursor 
points to. 
 
The user can hide (or show) the bar with the appropriate Main menu item: View > Status bar. 

7 Settings Overview 
The Settings dialog is available from the Main menu: Tools > Settings. All the settings are grouped into 
several sections of which the functions are described in the following paragraphs. The list of sections is 
placed on the left side of the dialog. By selecting a section from the list, the user opens a set of options. 

7.1 General Options  
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This section contains a set of general options that will be taken into account during all the operations carried 
out with the program. The user can switch between the following modes: 

� Verify data written. If this option is marked, every write-to-disk action is followed by the 
read-and-compare action. This feature may be helpful in case of running an unstable hard 
disk, however it will negatively affect the overall performance. 

� Enable data loss protection. Activate the option to force the program to work in the fail-safe 
mode (also referred to as data-loss protection mode), which ensures more safety for 
operations by maintaining the special journal of operations’ progress. In case of hardware 
malfunction, power outages or operating system failure, the modified partition may become 
corrupted and non-operable. However, the program will be able to complete the interrupted 
operation, thus "reviving" the partition. 

If the system has crashed during the operation in the fail-safe mode, insert the bootable 
Recovery CD and restart the computer. The program will automatically detect the journal of 
the interrupted operation and complete the operation. 

 
It is strongly recommended to enable this option. 

� Try to access non-BIOS disk cylinders. The option works only under Windows 95, 98, ME. 
When activated, the program performs a special procedure to define the disk capacity and 
does not use the value that is returned by BIOS. 

7.2 General Copy and Backup Options  
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This section contains a set of options that will be taken into account during copy and backup operations. The 
user can switch between the following modes: 
 

� HDD raw processing. Activate the option to copy a hard disk in the sector-by-sector mode to 
successfully process unknown file systems. However it is not recommended to enable this option 
when working with supported file systems as it takes more time to accomplish the operation. 

� Partition raw processing. Activate the option to copy a partition in the sector-by-sector mode to 
successfully process unknown file systems. However it is not recommended to enable this option 
when working with supported file systems as it takes more time to accomplish the operation. 

� Perform incremental copy. Once the complete copy of a hard disk is created, it can be used as a 
base for the incremental copy. Mark the option to make the program perform the exact bit-wise 
comparison of the previous data (saved in the parental copy) with the current data (that is actually the 
hard disk itself). After that only most recent information will be processed. It considerably decreases 
the amount of data written. 

� Skipping OS auxiliary files during backup operation. 
� Skipping archives stored in the archive database. If this option is marked, all backup images 

stored in the archive database will not be processed during the backup operation. It will considerably 
decrease the resulted image file and time to carry out the operation. 

 
In order to activate an option the user should mark the appropriate checkbox.  

7.3 E-Mail Options 

 
 
This section contains a set of options that will be taken into account during the Send log files and Send e-
mail notification operations. The user can define: 
 

� Outgoing mail server (SMTP). To send messages by using the built-in mail client, it is necessary to 
have access to a computer running an SMTP (Simple Mail Transfer Protocol) server. All outgoing 
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messages are first sent to the SMTP server, which in its turn delivers them to the required recipients. 
The address may be represented as a traditional Internet host name (e.g.: mail.com) or as an IP 
numeric address (e.g. xxx.xxx.xxx.xx). 

� User e-mail address. Specify an e-mail address that has been assigned by the Internet Service 
Provider or organization's e-mail administrator. 

� My outgoing server requires authentication. Activate the option to allow the program to make 
authentication on the server before sending messages. 
- User name. Enter the name that will be used to log in to the e-mail account. 
- Password. Enter the password that will be used to access the mail server. 
 

� Send e-mail notification on apply. Specify an e-mail to send notifications on the carried out 
operations.  
- Send mail in HTML format. Activate the option to create messages in the HTML format instead 
of plain text. 
- Send complete report after applying operations. Activate the option to create an in-depth report 
on the carried out operations and send it after performing the last operation. 
- Send graphical view of the disk sub-system before and after apply. Activate the option to allow 
the program to attach two pictures of the disk layout made before and after the operation is 
completed. 

 

 
Some features may be unavailable in the version of the product you have. To learn more 
about it please consult the Drive Copy Editions chapter. 

7.4 Operation Dependency Options 

 
 
This section contains a set of options that will be taken into account when the Send e-mail notification on 
apply function is enabled. By marking the appropriate operations the user can choose whether to receive an 
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e-mail notification after the particular operation is completed or not. However, the user will not be notified 
by e-mail in case operations (if any) require the system reboot.  
 

 
Some features may be unavailable in the version of the product you have. To learn more 
about it please consult the Drive Copy Editions chapter. 

7.5 Hot Processing Options  

 
 
This section contains a set of options that will be taken into account in case the Hot Processing mode is 
enabled. The Hot Processing mode is a part of the backup/copy operation that allows the program to process 
a disk without restarting the computer. The program forces the system to restart to obtain exclusive access to 
the processing data. The Hot Processing mode may be used to process locked partitions or any backup/copy 
operation. The user defines the method in this section. 
 
The user can also set a Temporary drive. This option defines a partition (by default – C:) for the Hot 
Processing temporary file. The temporary file will be deleted when the hot backup/copy is performed which 
may require a large amount of disk space. Should there not be enough space on drive C:, then another drive 
needs to be selected. 

7.6 Virtual Mode Options 
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� Allow virtual mode. In this section the user can choose whether to allow operations to carry out 
immediately or to place them on the List of Pending Operations for later execution. Just mark the 
option to enable virtual operations. 

� Close progress dialog automatically. Mark the option to automatically close the progress dialog 
when the required operation(s) is completed. 

 

 
Virtual mode can be particularly beneficial for such operations as Save to scheduler… 

8 Getting Information about Disks  
The user is able to view in-depth information on the properties of hard disks. The main tool to extract this 
information is the Disk Map. It represents the actual state of the computer’s hard disks. The Disk Map 
chapter is a detailed description on this topic. 
 
Generally the hard disks are represented on the map by rectangular bars, which also contain small-sized 
bars. The small-sized bars represent logical disks (partitions). When the user selects a large-sized bar, the 
Explorer bar displays information about the disk in a bright, graphical form.  
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The model and serial number of the disk serve as the title of the browsed page. The disk layout is shown in 
form of a circular graph, where the color of a sector corresponds to a file system of an appropriate partition. 
On the right the user may see a table, which contains the following information: 
 

� Type of hard disk (basic or dynamic), 
� Total size (in GB), 
� Information on geometry of the disk (amount of sectors per track, heads and cylinders). 

 
Below there is a list of wizards available for the user. If the user clicks a corresponding record the 
appropriate wizard will be started. All default values for the operation parameters will correspond to the 
disk’s settings. The list of wizards contains a detailed description of tasks that can be performed by the 
wizard. This nullifies the possibility of selecting the wrong wizard. 
 

 
 
When the user selects a small-sized bar (i.e. corresponding to a logical disk), the Explorer bar will display 
information on it as well. The page title will contain a drive letter, which is assigned to the disk. The disk 
layout graph will be colored in accordance with the volume ratio of the used space to the free space (the 
light colored sector). The table on the right will contain the following information: 
 

� Volume label (if available), 
� Type of the logical disk, 
� File system (represented by the color of the graph and the selected bar), 
� Total size, used space and free space (in GB or MB). 
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9 Copy Tasks  
This chapter lists various scenarios of copy operations which may be accomplished by the program. This has 
already been reviewed in the Basic concepts chapter. Here the user will find more useful recommendations 
and descriptions of operations. 

9.1 Copy Hard Disk 
In the Basic concepts chapter we mentioned about possible applications of this operation. The program 
provides the ability to clone hard disks of any file system. During the hard disk copying process, the 
program moves controlling records of used partitioning scheme, the bootstrap code and on-disk partitions. 
This operation cannot be substituted by simply copying all on-disk partitions.  
 
The operation can be accomplished with the Copy Hard Disk Wizard. The wizard is so well designed that 
the user simply needs to follow its easy instructions to make an exact copy of the disk.  

9.1.1 Starting  

There are several ways to start the Copy Hard Disk Wizard: 
 

� In the Main menu: select Wizards > Copy Hard Disk… 
� On the Common Tasks bar: click the Copy Hard Disk item of the Wizards menu. 
� In the Toolbar: click the Copy Hard Disk button. 
� Select a disk on the Disk map and click the Copy Hard Disk item on the page that appears in the 

Explorer bar. 
 

After following one of the above mentioned actions, the Welcome page of the wizard is displayed.  
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The Copy Hard Disk Wizard allows the user to configure the settings and then start the operation in 
accordance with the entered parameters. Here the user sets the parameters of the operation defining: 

� The hard disk to copy. Select a hard disk you want to copy 
� Copy parameters. The Copy Hard Disk Wizard allows the user to specify the following 

options:  
 

 

- Copy options. This section enables to switch between two options:  
Sector-to-sector copy mode (allows to process any file system, even unknown one).  
Perform incremental copy (once the complete copy of a hard disk is created, it can be 
used as a base for the incremental copy. Mark the option to make the program 
perform the exact bit-wise comparison of the previous data (saved in the parental 
copy) with the current data (that is actually the hard disk itself). After that only most 
recent information will be processed. It considerably decreases the amount of data 
written). 
- Resize options. This section enables to switch between two options: 
Remove free blocks between partitions. If this option is activated, the program does 
not keep blocks of free space between partitions on the targeted hard disk. 
Copy data and resize partitions proportionally. If this option is activated, the program 
proportionally changes the size of partitions keeping their relative order intact. The 
option can be useful when upgrading the hard disk to a larger one. 
- Verification options. This section allows the user to define whether the Surface test 
and/or the Writing Verification test will be accomplished during the operation. 

9.1.3 Results 

Depending on the user’s choice the Copy Hard Disk Wizard: 
 

� starts the operation 
� reconsiders it 

 
After the operation is completed the user receives a fully functional duplicate of the existing hard disk.  
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9.2 One Button Copy Wizard 
One of the fundamental features of the program is the ability to clone hard disks by pressing just one button, 
i.e. launching the One Button Copy Wizard. To successfully accomplish the operation your system should 
meet the following requirements: 
 

� at least two hard disks, one of which should contain data and the other is empty 
� the destination hard disk should have enough space to take contents of at least first partition of the 

source disk 

9.2.1 Starting 

There are several ways to start the One Button Copy Wizard: 

� In the Main menu: select Wizards > One Button Copy Wizard 
� On the Common Tasks bar: click the One Button Copy Wizard item of the Wizards menu.  

 

 
 

Actually, that is all. The Wizard displays its main window, where you can see source and destination disks 
and three available options: 
 

� Copy all sectors one to one (to process corrupted and unknown file systems - more time required) 
� Perform incremental copy (once the complete copy of a hard disk is created, it can be used as a 

base for the incremental copy. Mark the option to make the program perform the exact bit-wise 
comparison of the previous data (saved in the parental copy) with the current data (that is actually the 
hard disk itself). After that only most recent information will be processed. It considerably decreases 
the amount of data written) 

� Copy without free space blocks (to arrange partitions one after another)  
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� Resize proportionally (to proportionally change the size of partitions keeping their relative order 

intact) 

9.2.2 Results 

The operation will be automatically accomplished after a ten-second pause. In case you are willing to 
modify some of the default options, press the Pause button, to continue execution press Start. To interrupt 
the operation, press the Cancel button.  
 
By default the Progress dialog will be closed after the operation is successfully completed. In case there are 
some problems, the user can see it and find out what has happened.  

9.3 Copy Partition 
The copying of partitions can be used either for cloning sample partitions or for making backup copies of 
working partitions.  
 
The user can duplicate partitions to protect oneself from downtime in case of a system malfunction. The 
partition can be copied back to the original place within a few minutes or can be used simply for copying 
separate files.  
 
The program duplicates all usable partition data including files, the exact structure of directories and file 
system metadata: location of files, security information, access quotas and so on. The program allows to 
copy partitions only to blocks of free space. 

9.3.1 Starting  

There are several ways to start the Copy Partition Wizard: 
 

� In the Main menu: select Wizards > Copy Partition… 
� On the Common Tasks bar: click the Copy Partition item of the Wizards menu. 
� In the Toolbar: click the Copy Partition button. 
� Select a disk on the Disk map and click the Copy Partition item on the page that appears in the 

Explorer bar. 
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After following one of the above mentioned actions, the Welcome page of the wizard is displayed.  
 

 

9.3.2 Settings  

The Copy Partition Wizard allows the user to configure the settings and then start the operation in 
accordance with the entered parameters. Here the user sets the parameters of the operation defining: 
 

� The partition to copy. Select a partition you want to copy 
� Destination disk. Select a hard disk with free space enough for performing the copy partition 

operation 
� Copy parameters. The Copy Partition Wizard allows the user to specify the following options: 

 
- Copy the partition with resize. This option gives the possibility to copy the partition to a block of 
free space, which is smaller than the partition itself.  
- Partition size. Define the size (in Mb) of the copied partition.  
- Free space before. Define the position (in Mb) of the copied partition relative to the beginning of 
the available range of disk space.  
- Free space after. Define the amount of trailing free space (in Mb) at the end of the available range 
of disk space.  
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9.3.3 Results 

Depending on the user’s choice the Copy Partition Wizard: 
 

� starts the operation 
� reconsiders it 

 
After the operation is completed the user receives a fully functional duplicate of the existing partition.  

10 Scheduling Operations 
The program allows the user to automate the backup/copy operations. The utility for this purpose is referred 
to as the embedded Scheduler, which is used to specify the time for the execution of the copy operation. 
There are two categories for time settings (these correspond to appropriate items in the Schedule type menu): 

� Initiating the copy operation by an event: 

- One time only (i.e. the Once item) 
- When system starts (i.e. the At System Startup item) 
- When the user logs on (i.e. the At Logon item). 

� Initiating the copy operation periodically (i.e. Daily, Weekly, Monthly). 

The user needs to select one of the variants. Depending on the choice, the scheduler will display a form that 
allows the user to set the schedule. Let us review available variants of settings and examine situations for 
which these parameters would be most suitable. 
 
There are situations when the user wants to make a major update of a program project or make serious 
modifications in the system settings. For every mentioned case it is possible to schedule the copy operation 
only once by selecting the appropriate Once item in the Scheduler’s menu. The bottom section of the dialog 
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window displays fields that help you define the date and time when the operation should begin. 
 

 
 
 

 

To run the task in the log-off mode, please specify administering login info by following the 
appropriate link in the left lower corner of the page. 
 
The Shutdown System on Complete option enables to automatically switch off the computer on 
the successful accomplishment of the operation. 

 
When making serious system changes, the start of the copy operation can be connected with the user’s logon 
or with the system start up. It optimally corresponds to the At Logon or the At System Startup items of the 
menu. The lower section of the dialog window will display fields that help you specify conditions for 
starting the operation: 
 

� The operation begins automatically with every logon 
� The operation is started on the next logon after which the task will be deleted from the scheduler. In 

this case the backup operation will be performed only once. 
� The operation is started on the next logon and is then repeated at every logon. The length of the 

interval between operations can be configured here. 
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As described earlier on where the user needs to copy data every evening, in this case the Daily menu item in 
the Scheduler’s window needs to be selected. After selecting the option, the lower section of the window 
will allow the user to define the following parameters of the operation initiation: 
 

� The time when the backup operation starts 
� A period during which the backup operation will be performed (in days) 
� The date when the backup operation will be started first and the date after which the task will be 

deleted from the scheduler's waiting list 
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There are also some situations when it is necessary to select the Weekly item of the Schedule type menu. 
The lower section of the window will allow the user to define the following parameters of the start of the 
operation: 
 

� The time when the backup operation starts 
� A period during which the backup operation will be performed (in weeks) 
� Days of the week, when the operation will be started 
� The date when the backup operation will be started for the first time and the date when the operation 

will cease to run. 
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Finally, copying can be accomplished on a monthly basis. To set the times, the user needs to select the 
Monthly item of the Schedule type menu and then define the following additional parameters: 
 

� The time when the backup starts 
� A day of a month when the backup will starts 
� The date when the backup operation will be started for the first time and the date when the operation 

will cease to run. 
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After completing the schedule please check the settings on the last page of the Wizard (the Operation 
schedule section). 
 
All scheduled tasks are placed in a separate list, which can be retrieved by clicking the Scheduled Tasks tab 
in the Explorer bar: 
 

 
 
On every task the user can get in-depth information, including: 
 

� The task name 
� The full path to the generated script of the task 
� Scheduled time of launch 
� Statistics on the last launch 
� Scheduled time of the next launch 
� Used account information 
� Comments to the task 

 
To easily manage tasks, the program enables to arrange them according to a certain characteristic just by 
clicking on the required property. 
 

 
This feature can be particularly beneficial when the Scheduled Tasks list contains too many 
items. 

 
It is also possible to enable/disable, rename, delete, refresh or modify additional properties of the selected 
task. 
 
To modify additional properties of the selected task with the Task Editor, the user should select the 
Properties item of the context menu, which can be called by a right-click on the appropriate task. 
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The dialog window has two tabs - General and Schedule. The General tab contains: 

 
� The full path to the program-interpreter of the macro-commands which describes the scheduled task 
� The line of parameters for starting the interpreter (i.e. the task described in macro-language) 
� Comments referring to the task 
� The option of enabling/disabling the task. 

 
The Schedule tab contains the timetable of the task, which the user can modify. In order to apply the 
changes, the user needs to click the Apply button at the foot of the dialog. 

10.1 Save to Scheduler 
Besides automating copy operations, the program provides the ability to schedule any virtual operation 
placed on the List of Pending Operations. The automation of the program’s operations is particularly 
effective when the user has to repeat a sequence of actions on a regular basis. It enables to execute certain 
routine operations without the user being involved. Moreover it allows an optimization of your computer’s 
work-load. 
 
In order to start the operation the user should take the following steps:  
 
1. Call the Save to Scheduler dialog in the Main menu: Tools > Save to Scheduler… 
 
2. Specify the time for the execution of operations on the List of Pending Operations.  
 

 

This command is unavailable if there are no operations on the List of Pending Operations. 
 
To learn more about how to set a timetable for execution please consult the Scheduling 
Operations chapter. 
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11 Partition Management 
In this chapter you will find all the information necessary to carry out partitioning operations supported by 
the program. 

11.1 Create Partition 
The program provides the ability to create new partitions by using the DOS partitioning scheme. 

11.1.1 Restrictions 

1. Do not use the Create Partition function in order to undelete the last deleted partition. 
2. The program cannot create new partitions on Dynamic Disks. The current version of the program supports 
only hard disks that use the DOS partitioning scheme (in Windows 2000 and XP these disks are named 
Basic Disks). 
3. According to the rules of the DOS partitioning scheme, the following combinations of partitions cannot be 
created: 

� Two Extended Partitions on one hard disk 
� Five or more Primary partitions on one hard disk 
� If there is an Extended Partition on the disk, only three Primary partitions are allowed 

 
4. The program allows creating new partitions only within blocks of unpartitioned space. It cannot convert a 
free space on an existing partition to a new partition. 

11.1.2 Starting 

In order to start the operation the user should take the following steps: 
 
1. Select a block of free space on the Disk Map. 
 
2. Call the Create Partition dialog to define appropriate settings. There are several ways to do it: 

 
� Select in the Main menu: Partition > Create Partition. 
� Call the popup menu for the selected partition (right click of the mouse button) on the Disk Map, 

then select the menu item: Create Partition. 

11.1.3 Settings 

Define the future partition parameters with the Create Partition dialog. Initially the program suggests some 
consistent values for all parameters. In most cases, the user can just press the Yes button to confirm the 
operation. 
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� Define whether the partition will be Primary, Extended or Logical. Select the desired type of the 
new partition from this pull-down list. As a matter of fact, the available alternatives fundamentally 
depend on the type of the selected block of free space - within the Logical free space, only Logical 
partitions can be created; Within the Primary free space, both Primary partitions or the Extended 
Partition can be created. 

� Partition Size. Define the size (in MB) of the new partition. 
� Free space before. Define the position (in MB) of the new partition relative to the beginning of the 

block of free space. 
� Free space after. Define the amount of trailing free space (in Mb) at the end of the new partition. 

 

 

Partition size and position may also be defined by using the drag-and-drop technique. To do 
that, just carry out the required operation on the Disk Map. The virtual operations are to be 
available. 

 
� File system for new partition. From the pull-down list select a file system the newly created 

partition will be formatted to, otherwise the partition will remain unformatted (so that it will not be 
ready to use). 

 
In addition, there is the possibility to make further detailed settings (although the default values will do in 
most cases). To activate the advance mode, the user needs to click the More options button at the foot of the 
dialog page. Depending on the file system, the following options become available: 
 

 
 

� Whether the surface test will be performed. Mark the option to make the program perform the 
surface test on the formatted partition. In this case, the program will find bad and unstable sectors 
and mark them unusable in the file system metadata. 
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� The amount of sectors per boot. This parameter is available exclusively for FAT16 and FAT32 file 

systems. Set the number of sectors to be reserved for the boot area on the partition with this spinner 
control. 

� The amount of root entries. This parameter is available exclusively for FAT16 file system. Set the 
maximum amount of files/directories to be placed in the Root Directory on the FAT16 partition. 

� The amount of sectors per cluster. Define the Cluster Size for the formatted partition with this 
spinner control. 

11.1.4 Results  

After the operation is completed the user receives a fully functional partition. 

11.2 Format Partition  
Any partition should contain some file system to be used for keeping data. The process of installing a file 
system is commonly known as formatting. A huge variety of file systems have been developed these days. 
The program provides the ability to format existing or newly created partitions of the following file systems: 
 
   - FAT12 & FAT16 
   - FAT32 
   - NTFS 
   - Ext2 
   - Ext3 
   - Linux Swap v. 2 
   - HPFS 

11.2.1 Starting 

In order to start the operation the user should take the following steps: 
 
1. Select a block of free space on the Disk Map. 
 
2. Call the Format Partition dialog to define appropriate settings. There are the following ways to do it: 

 
� Select in the Main menu: Partition > Format Partition. 
� Call the popup menu for the selected partition (right click of the mouse button) on the Disk Map, 

then select the menu item: Format Partition. 

11.2.2 Settings 

Define parameters of the formatting operation with the Format Partition dialog. Initially the program 
suggests some consistent values for all parameters. In most cases, the user can just press the Format button 
to confirm the operation. 
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� File system. Select the desired file system type from this pull-down list. In fact, the program displays 
only file systems that can be correctly placed to the selected partition, taking the capacity of the 
selected partition into account. 

� Volume label. Enter a label for the selected partition in this textual field. The Volume label is an 
irrelevant parameter of a logical drive that can be used for drive identification. 

 
In addition, there is the possibility to make further detailed settings (although the default values will do in 
most cases). To activate the advance mode, the user needs to click the More options button at the foot of the 
dialog page. Depending on the file system, the following options become available: 
 

 
 

� Use OS built-in routine. Mark the option to restrict the available values according to the used OS. 
� Whether the surface test will be performed. Mark the option to make the program perform the 

surface test on the formatted partition. In this case, the program will find bad and unstable sectors 
and mark them unusable in the file system metadata. 

� The amount of sectors per boot. This parameter is available exclusively for FAT16 and FAT32 file 
systems. Set the number of sectors to be reserved for the boot area on the partition with this spinner 
control. 

� The amount of root entries. This parameter is available exclusively for FAT16 file system. Set the 
maximum amount of files/directories to be placed in the Root Directory on the FAT16 partition. 

� The amount of sectors per cluster. Define the Cluster Size for the formatted partition with this 
spinner control. 

11.2.3 Results  

After the operation is completed the user receives a fully functional partition formatted to the file system 
specified. 

11.3 Delete Partition 
The program allows the user to delete partitions on hard disks partitioned with the DOS partitioning scheme. 
The program removes references to the partition from the Partition Table, so that the information from the 
deleted partition becomes inaccessible. The resulted disk space can be used to create new partitions.  
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Contents of the deleted partition do not disappear from the disk but merely are unavailable for the operating 
system. 

11.3.1 Starting 

In order to start the operation the user should take the following steps: 
 
1. Select a block of free space on the Disk Map. 
 
2. Call the Delete Partition dialog to define appropriate settings. There are several ways to do it: 

 
� Select in the Main menu: Partition > Delete Partition. 
� Call the popup menu for the selected partition (right click of the mouse button) on the Disk Map, 

then select the menu item: Delete Partition. 

11.3.2 Settings  

Define parameters of the delete operation with the Delete Partition dialog. 
 

 
 

� Enter the volume label to confirm deleting. To confirm the deletion of the selected partition, enter 
its Volume Label. The actual Volume Label value is displayed above. 

� Do not ask volume label next time. Mark the option to inhibit confirmation of the partition deletion. 

11.3.3 Results 

The deletion of a partition takes only a fraction of a second. However, the program waits until Windows 
completes the modification of the disk layout. 

11.4 Undelete Partition 
When deleting a partition, disk management software only removes references to it in the Partition Table so 
that a previously deleted partition can still be recovered (in case of valid restoration of the record in the 
Partition Table). The program provides the ability to find and recover these partitions. This function 
minimizes the hazard of occasional partitions deletion and is usually known as undelete. 
 
A restored partition will be fully functional, as long as other partitions were not created, moved or exceeded 
the disk space occupied by the partition. That is why the program enables the Undelete Partition function 
only for blocks of free space. 
 
The operation can be accomplished with the Undelete Partition Wizard. 

11.4.1 Starting 
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There are several ways to start the Undelete Partition Wizard: 
 

� In the Main menu: select Wizards > Undelete Partitions… 
� Select a disk on the Disk map and click the Recover Lost Partitions item on the page that appears in 

the Explorer bar. 
 
After following one of the above mentioned actions, the Welcome page of the wizard is displayed. 
 

 

11.4.2 Settings 

The Undelete Partition Wizard allows the user to configure the settings and then start the operation in 
accordance with the entered parameters. Here the user sets the parameters of the operation defining: 
 

� Free blocks to scan for lost partitions. Choose a free block from a tree-like list of available disks 
and their partitions. 

� Manual setting of search criteria. The user can manually specify a particular file system to look for 
and define search criteria. Good knowledge of hard disk structure is required. 

11.4.3 Results 

After the operation is completed the user receives a fully functional partition. 

11.5 Changing Partition Attributes 
This chapter explains how the user can change partition attributes (Active flag, Hidden flag, Partition ID, 
Volume Label, etc.). 

11.5.1 Mark Partition Active/Inactive 

The program enables to set Active/Inactive flag for primary partitions of the hard disk. By default the 
operating system will boot from the active (bootable) partition at startup. 
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In order to mark partition Active/Inactive the user should take the following steps: 
 
1. Select a primary partition on the Disk Map. 
 
2. There are several ways to Mark Partition Active/Inactive: 
 

� Select in the Main menu: Partition > Mark Partition Active/Inactive. 
� Call the popup menu for the selected partition (right click of the mouse button) on the Disk Map, 

then select the menu item: Mark Partition Active/Inactive. 
 

 
 

 
There can only be one active partition on a hard disk, otherwise the operating system will fail 
to boot. 

 
3. The operation will be performed immediately after confirmation. 

11.5.2 Hide/Unhide Partition 

The program allows the user to Hide/Unhide primary and logical partitions. The operating system does not 
mount hidden partitions, thus preventing access to their contents. 
 
In order to Hide/Unhide a partition the user should take the following steps: 
 
1. Select a partition on the Disk Map.  
2. There are several ways to Hide/Unhide partitions: 
 

� Select in the Main menu: Partition > Hide/Unhide Partition. 
� Call the popup menu for the selected partition (right click of the mouse button) on the Disk Map, 

then select the menu item: Hide/Unhide Partition. 
 

 
It is strongly recommended not to hide the system partition, otherwise the operating system 
will fail to boot. 

 
3. The operation will be performed immediately after confirmation. 

11.5.3 Set Label of a Partition 

The Partition Label is a small textual field (up to 11 characters) that is located in the partition's boot sector. 
This value is detectable by any partitioning tool; it is used for notification purposes only. 
 
In order to change a partition label the user should take the following steps: 
 
1. Select a partition on the Disk Map.  
 
2. Call the Change Volume Label dialog to define appropriate settings. There are several ways to do it: 
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� Select in the Main menu: Partition > Modify > Change Volume Label. 
� On the Explorer bar: click on the current volume label. 
� Call the popup menu for the selected partition (right click of the mouse button) on the Disk Map, 

then select the menu item: Change Volume Label. 
 
3. Define the label of the partition with the Change Volume Label dialog: 
 

 
 
New volume label. Enter the new value of the Partition Label. The length of the Label is limited to 11 
characters. 
 
The dialog also displays the current partition label.  
 
4. The operation will be performed immediately after confirmation. 

11.5.4 Change Partition ID 

Partition ID is an identifier of a file system that is placed in the partition. Partition ID is saved in the 
Partition Table; it is used to quickly detect partitions of supported types. By manually changing the Partition 
ID value, it is possible to manipulate the accessibility of partitions. 
 
In order to change a Partition ID the user should take the following steps: 
 
1. Select a partition on the Disk Map.  
 
2. Call the Change Partition ID dialog to define appropriate settings. There are several ways to do it: 
 

� Select in the Main menu: Partition > Modify > Change Partition ID… 
� On the Explorer bar: click on the current partition ID. 
� Call the popup menu for the selected partition (right click of the mouse button) on the Disk Map, 

then select the menu item: Change Partition ID… 
 
3. Define the ID of the partition with the Change Partition ID dialog: 
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� Predefined ID. Select from the pull-down list ID values for various file systems. 
� Enter ID manually. The textual field contains a hexadecimal presentation of the Partition ID. 

Generally, the Partition ID should be presented as 1-2 digits hexadecimal number; only hexadecimal 
digits {0..9, A..F} are allowed to be used. 

 
4. The operation will be performed immediately after confirmation. 

11.5.5 Change Serial Number of a Partition 

FAT16, FAT32, HPFS and NTFS file systems include the Serial Number parameter. The partition's Serial 
Number is saved in the boot sector; its value is generated while formatting a partition. 
 
The program enables to modify the partition's Serial Number on formatted FAT16, FAT32, HPFS and NTFS 
partitions without re-formatting. 
 
In order to start the operation the user should take the following steps: 
 
1. Select a partition on the Disk Map.  
 
2. Call the Change Partition Serial Number dialog to define appropriate settings. There are several ways to 
do it: 
 

� Select in the Main menu: Partition > Modify > Change Serial Number. 
� On the Explorer bar: click on the current serial number. 

 
3. Define the parameter value with the Change Partition Serial Number dialog. 
 

 
 
New serial number. The user can enter the new Serial Number value in this textual field. The Serial 
Number should contain 8 hexadecimal figures (0..9 or A..F). The operation cannot be accomplished until the 
user enters all 8 symbols. 
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12 Hard Disk Management 
This chapter lists various scenarios of hard disk operations which may be accomplished by the program. 

12.1 Update MBR 
The program allows the user to overwrite the current bootable code in the MBR (Master Boot Record) by 
the standard bootstrap code.  
 
This feature can repair corrupted bootable code on a hard disk as a result of boot virus attacks or 
malfunction in the boot managing software. 
 
In order to start the operation the user should take the following steps: 
 
1. Select a hard disk on the Disk Map.  
 
2. There are several ways to run the operation: 
 

� Select in the Main menu: Hard Disk > Update MBR. 
� Call the popup menu for the selected hard disk (right click of the mouse button) on the Disk Map, 

then select the menu item: Update MBR. 
 

 
 
3. The operation will be performed immediately after confirmation. 

12.2 Change Primary Slot 
Operating systems use the following partitions enumeration: 
 
In Linux: 
In Linux, every partition has a special symbolic name that encodes a hard disk containing a partition, and a 
partition itself. Partitions are addressed and accessed by using their symbolic names. Symbolic names are 
automatically generated by Linux in accordance with the order of hard disks in BIOS and the order of 
partition records in the Partition Table. The modification of primary partitions enumeration can lead to the 
changing of paths to some important resources. 
 
In DOS: 
The last versions of MS-DOS use a rather sophisticated algorithm for drive letters assignment. A drive letter, 
which is assigned to a partition, depends on the order of records in the Partition Table. The modification of 
primary partitions enumeration affects the drive letters assignment. In early versions of  
MS-DOS, it can even lead to the unavailability of a partition. In any case, the user may want to change the 
enumeration of primary partitions.  
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In order to modify the enumeration of partitions the user should take the following steps: 
 
1. Select a hard disk on the Disk Map.  
 
2. Call the Change Primary Slot dialog to define appropriate settings. There are several ways to do it: 
 

� Select in the Main menu: Hard Disk > Change Primary Slot. 
� Call the popup menu for the selected hard disk (right click of the mouse button) on the Disk Map, 

then select the menu item: Change Primary Slot. 
 

 
 
3. The dialog displays the actual enumeration of Primary Partitions in the Partition Table (it exhibits the 
order of appropriate records, which refer to primary partitions in the primary part of the Partition Table 
referencing records. The top part of the dialog displays the enumeration order of partitions with the 
parameters that can help to distinguish partitions: 
   - Slot 
   - Volume 
   - Partition type 
   - File system 
   - Partition size  
   - Volume label 
 
There are two buttons on the right of the list of primary partitions, which allow the user to move the selected 
partition up and down within the primary part of the Partition Table. 
 
4. The operation will be performed immediately after confirmation. 

12.3 Change SID 
SID - Security IDentifier, the binary structure that is associated with some object in the system, is used to 
distinguish between user access privileges in workgroup local networks. By default, the SID Changer 
searches Windows installations and then changes SIDs in the found Windows instances to automatically 
generated random SID values.  
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The program provides the ability to change SIDs:  
 
1. Select a hard disk on the Disk Map.  
 
2. Call the Change SID dialog to define appropriate settings. There are several ways to do it: 
 

� Select in the Main menu: Hard Disk > Change SID. 
� Call the popup menu for the selected hard disk (right click of the mouse button) on the Disk Map, 

then select the menu item: Change SID. 
 

 
 
3. Generate SID based on BOOT.INI files information. By default, the utility searches for BOOT.INI 
files on all partitions to extract information on Windows installations and then performs modifying of the 
found SIDs by automatically generated random values.  
 
The user can specify some definite directories for search in addition to ones set in BOOT.INI files, or inhibit 
analyzing BOOT.INI files at all. It is also possible to set a SID value manually. 
 

 
The SID changer utility can be applied only to NT and Win2k installations.  

13 Build Recovery Media  
The program provides the possibility to prepare a set of recovery tools on external media (CD, DVD or 
floppy disks). The tool set can be of assistance in case of operating system corruption, which means that the 
user is able to boot the computer even when the operating system is not able to do so. Creation of such 
recovery tools is performed with the Recovery Media Wizard.  
 
Starting  
To start the Recovery Media Wizard the user needs to select the Recovery Media Builder item of the Wizards 
menu on the Common Tasks bar. Then the Welcome page of the wizard is displayed. 
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Settings  
The Recovery Media Wizard allows the user to configure the settings and start the operation in accordance 
with the entered parameters. In our case we set the parameters of the future recovery tool by defining: 
  

� Type of the recovery media the user is creating. The recovery tools can be placed either on a 
CD/DVD disc or on a floppy disk. 

 

 
 

� Contents of the recovery set. The recovery tools can include the standard Recovery Media image 
(included in the installation package) or software defined by the user. In the last case the user can 
record a prepared image by setting the path to the image file on the disk. 
 

 
 

� A recording device. The appropriate external media (CD/DVD or a floppy disk) needs to be inserted 
into the selected device. 

� CD/DVD writing parameters (in case the user selects this kind of media). Writing parameters 
include writing speed (maximum or minimum) and the ability of ejecting the recorded disc after 
completing the operation. 
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The program supports CD-R, CD-RW, DVD-R, DVD+R, DVD-RW, DVD+RW and also DVD-R, DVD+R 
double layer discs. If the inserted disc is not empty, the Wizard suggests the user erasing its contents. When 
the user confirms the operation, the program deletes the re-writable disc's contents and begins the recording 
process.  

14 Extra Functionality 
This chapter describes the supplementary functionality available in the program. 

14.1 View Partition/Hard Disk Properties 
The program enables to obtain in-depth information on the properties of hard disks/partitions. Besides the 
general information, such as capacity, used space or file system type it provides the possibility to get info on 
a hard disk geometry, cluster size, exact partition location, etc. 
 
In order to view properties of a partition/hard disk the user should take the following steps: 
 
1. Select a partition/hard disk on the Disk Map. 
 
2. Call the popup menu for the selected partition/hard disk (right click of the mouse button) on the Disk 
Map, then select the menu item: Properties… 
 

 
 
3. The provided information is grouped according to its properties, thus select the required tab and get the 
information you need. 

Copyright© 1994-2008 Paragon Software Group. All rights reserved. 



Paragon Drive Copy™ 9.0 49 User Manual 

 
14.2 Mount Partition 
The program allows the user to assign or remove drive letters of existing formatted partitions. 

14.2.1 Assign Drive Letter 

In order to mount a partition the user should take the following steps: 
 
1. Select a partition on the Disk Map.  
 
2. Call the Add Drive Letter dialog to define appropriate settings. There are several ways to do it: 
 

� Select in the Main menu: Partition > Assign Drive Letter… 
� Call the popup menu for the selected partition (right click of the mouse button) on the Disk Map, 

then select the menu item: Assign Drive Letter… 
 
3. Define a drive letter for the selected partition with the Add Drive Letter dialog. Initially the program 
suggests some consistent value for this parameter. So the user may just press the Yes button to confirm the 
operation. 
 

 
 
Assign the following drive letter. The pull-down list contains vacant drive letters that can be associated 
with the selected partition. Assign a drive letter to a non-mounted partition, or change the existed drive letter 
for already mounted partition. 
 
4. The operation will be performed immediately after confirmation. 

14.2.2 Remove Drive Letter 

In order to unmount a partition the user should take the following steps: 
 
1. Select a partition on the Disk Map.  
 
2. Call the Remove Drive Letter dialog to define appropriate settings. There are several ways to do it: 
 

� Select in the Main menu: Partition > Remove Drive Letter. 
� Call the popup menu for the selected partition (right click of the mouse button) on the Disk Map, 

then select the menu item: Remove Drive Letter. 
 

Copyright© 1994-2008 Paragon Software Group. All rights reserved. 



Paragon Drive Copy™ 9.0 50 User Manual 

 

 
 

 

Modifying drive letter of the system partition will result in inability to boot the operating 
system. 
 
After having processed partitions with installed software, some programs may not run 
properly. 

 
3. The operation will be performed immediately after confirmation. 

14.3 Test Surface 
The program allows performing additional surface tests on existing partitions and blocks of free space.  
 
In order to start the surface test the user should take the following steps: 
 
1. Select a partition or a block of free space on the Disk Map.  
 
2. Call the Test Surface dialog to define appropriate settings. There are several ways to do it: 
 

� Select in the Main menu: Partition > Test Surface… 
� Call the popup menu for the selected partition (right click of the mouse button) on the Disk Map, 

then select the menu item: Test Surface… 
 

 
 
Surface test level. Choose the level of the test procedure. 
 
3. The operation will be performed immediately after confirmation. 

14.4 Check File System Integrity 
The program can check the file system integrity on existing partitions. This function can be used for 
detecting file system errors before performing operations on a partition. 
 
Most useful operations require the targeted partition to have a valid file system to be processed. 
 
In order to start the system integrity check the user should take the following steps: 
 
1. Select a partition on the Disk Map or on the List of Partitions.  
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2. Call the Check File System Integrity dialog to define appropriate settings. There are several ways to do it: 
 

� Select in the Main menu: Partition > Check File System Integrity. 
� Call the popup menu for the selected partition (right click of the mouse button) on the Disk Map, 

then select the menu item: Check File System Integrity. 
 
3. The operation will be performed immediately after confirmation. 

14.5 Send Log Files 
The program allows the user to simplify the procedure of sending support requests to the Paragon Support 
Team. In case of having difficulties with handling the program, the user, with the help of this very function, 
can address the company support engineers and provide them with all the information they need such as disk 
layout, performed operations, etc. in order to tackle the encountered problem. Information of that kind is 
stored in Log files. 
 
In order to start the operation the user should take the following steps:  
 
1. Call the Send Log Files dialog in the Main menu: Tools > Send Log Files 
 
2. Give a detailed description on the encountered problem. 
 

 
 
By clicking the Send button the built-in mail client will generate a template request with attached 
compressed log files and then send it to the Paragon Support Team. 

14.5.1 Log Files 

Log files are simple textual files that can be opened by any text editor. There are several log files 
automatically generated by the program: 
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Stubact.log Contains in-depth information on parameters and 
performance of all operations carried out by the program 

Pwlog.txt Besides brief overview on operations it also contains 
detailed information about the state of all hard disks 

Cdb.log Contains low-level information on the CD/DVD devices 
used in the system 

BioNTlog.txt 
or 

It is an OS-dependent supplementary log file derived from 
Bioxx.dll. It may contain valuable information on Windows 



Paragon Drive Copy™ 9.0 52 User Manual 

 
Bio95log.txt family operating systems 
 

 

Log files do not contain any confidential information on the operating system settings or the 
user documents. 
 
The Send Log Files function is only available when outgoing mail server (SMTP) and the user 
e-mail address are properly set. To learn more about it please consult the Settings Overview 
chapter. 

15 Glossary  
Active partition is a partition from which an x86-based computer starts up. The active partition must be a 
primary partition on a basic disk. If you use Windows exclusively, the active partition can be the same as the 
system volume. 
In the DOS partitioning scheme, only Primary Partitions can be active due to limitations of the standard 
bootstrap. 
 
Cluster is the smallest amount of disk space that can be allocated to hold a file. All file systems used by 
Windows organize hard disks based on clusters, which consist of one or more contiguous sectors. The 
smaller the cluster size, the more efficiently a disk stores information. If no cluster size is specified during 
formatting, Windows picks defaults based on the size of the volume. These defaults are selected to reduce 
the amount of space that is lost and the amount of fragmentation on the volume. A cluster is also called an 
allocation unit. 
 
Extended Partition is a type of partition that you can create only on basic master boot record (MBR) disks. 
Extended partitions are useful if you want to create more than four volumes on a basic MBR disk. Unlike 
primary partitions, you do not format an extended partition with a file system and then assign a drive letter 
to it. Instead, you create one or more logical drives within the extended partition. After you create a logical 
drive, you format it and assign it a drive letter. An MBR disk can have up to four primary partitions, or three 
primary partitions, one extended partition, and multiple logical drives. 
 
File system metadata. The servicing structures of a file system, which contain information about allocating 
files and directories, security information etc, are named file system metadata. File system metadata are 
invisible for users and ordinary applications because accidental modifications of the metadata usually make 
a partition unusable. 
 
Hard disk geometry. Traditionally, the usable space of a hard disk is logically divided into Cylinders, 
Cylinders are divided into Tracks (or Heads), and Tracks are divided into Sectors. 
 
The triad of values {[Sectors-per-Track], [Tracks-per-Cylinder], [Amount-of-Cylinders]} is usually named 
Hard Disk Geometry or C/H/S geometry. 
Tracks and Cylinders are enumerated from "0", while Sectors are enumerated beginning with "1". 
These disk parameters play an essential role in the DOS Partitioning scheme. The alignment of partitions 
takes the parameters of the hard disk geometry into consideration. 
 
Modern hardware uses an advanced scheme for the linear addressing of Sectors, which assumes that all on-
disk sectors are continuously enumerated from “0”. To allow backward compatibility with older standards, 
modern hard disks can additionally emulate C/H/S geometry. 
 
Hidden partitions. The concept of hidden partitions was introduced in the IBM OS/2 Boot Manager. 
Operating systems do not mount "hidden" partitions, which prevents access to their contents. 
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A method of hiding partitions consists in changing the Partition ID value that is saved in an appropriate 
entry of the Partition Table. This is achieved by XOR-ing the Partition ID with the 0x10 hexadecimal value. 
 
This method only works when the set of usable Partition ID values is very limited, since large sets of usable 
Partition IDs can lead to confusing file system types; for example, Ext2 partitions are marked with the 0x83 
Partition ID value. A hidden Ext2 partition would be marked with the 0x93 Partition ID value, which is 
identical with the Amoeba File system Partition ID. 
 
Master File Table (MFT) is a relational database that consists of rows of file records and columns of file 
attributes. It contains at least one entry for every file on an NTFS volume, including the MFT itself. MFT is 
similar to a FAT table in a FAT file system. 
 
MBR & 1st track of the hard disk is the 0th sector of the disk. MBR (Master Boot Record) contains 
important information about the disk layout: 
- The partitioning scheme. 
- The starting records of the Partition Table. 
- The standard bootstrap code (or the initial code of boot managers, disk overlay software or boot viruses). 
 
Generally, the 0th sector is used for similar purposes in all existing partitioning schemes. 
The capacity of the MBR is not sufficient to place sophisticated boot programs. This means that the on-boot 
software uses the entire 0th track of the hard disk in addition to the 0th sector because it is not included in 
any partition. For example, boot managing utilities such as LILO, GRUB and Paragon Boot Manager are 
located in the 0th track. 
 
Partition ID (or File system ID) is the identifier of a file system that is placed in the partition. The partition 
ID is used to quickly detect partitions of supported types. Some of the operating systems rely completely on 
the Partition ID when distinguishing supported partitions, while others again do not.  
The partition ID is saved in appropriate entries of the Partition Table. It takes up only 1 byte of space. 
 
Partition Label (sometimes also referred to as Volume Label) is a small textual field (up to 11 characters) 
that is located in the partition's boot sector. This value is used for notification purposes only. It is detectable 
by any partitioning tool including DOS' FDISK utility. 
 
Modern operating systems use other methods to save the Volume Label within the file system, e.g. as a 
special hidden file. The Volume Label is able to contain a relatively large amount of text in multiple 
languages. In general, the Volume Label and the Partition Label are rather different. 
 
Partitioning scheme is a set of rules, constraints and the format of on-disk structures that keep information 
of the partitions that are located on the hard disk. There are several partitioning schemes, which can be used. 
The most popular partitioning scheme is the so-called DOS partitioning scheme. It was introduced by IBM 
and Microsoft to use multiple partitions in the disk subsystems on IBM PC compatible computers. 
 
Another popular partitioning scheme is the so-called LDM (Logical Disks Model) that originates from UNIX 
mainframe systems. The Veritas Executive accommodates the simplified version of LDM to the Windows 
2000 operating system. 
 
Windows 2000 and XP support two quite different partitioning schemes: the old DOS partitioning scheme 
and the new Dynamic Disk Management (DDM). The problem is that older versions of Windows do not 
support DDM. In addition, most hard disk utilities do not support it as well. 
 
Recovery Media is a CD or DVD (or even a floppy disk) from which the user can boot and recover the 
system. 
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Root Directory is the top-level directory of a formatted logical drive. The Root Directory includes other 
files and directories. 
In modern file systems (e.g. Ext2/Ext3, FNTFS and even FAT32), the Root Directory does not differ from 
other directories in properties. This is not the case for old FAT12 and FAT16 file systems. 
 
Serial Number. In the DOS partitioning scheme, every hard disk and every partition has a Serial Number, 
which consists of 32 bits and is represented by an 8-figure hexadecimal value.  
 
The hard disk's Serial Number is stored in the MBR. Its value is assigned when the MBR sector is initialized 
by standard disk managing tools from Microsoft, such as Windows Disk Administrator and FDISK utility.  
 
In fact, the hard disk's Serial Number is not important for most operating systems and software. It is known 
that Windows NT, 2000 and XP store hard disks’ Serial Number values in the database of assigned drive 
letters. 
 
A partition's Serial Number is stored in its Boot Sector (in FAT16, FAT32 and NFTS file systems). Its value 
is assigned when the partition is formatted. In fact, the partition's Serial Number does not play an important 
role for most operating systems and software. 
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