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1 Introduction 
If somebody asks you which part of your computer is the most important, you’ll undoubtedly answer – a hard disk. You can 
change many things in your PC but a hard disk needs a special treatment because it keeps the most valuable – your information. 
As any important thing a hard disk requires your care. Giving some consideration to it you are able to increase efficiency of your 
work.  
 
So, how can you optimize the disk system? A common problem that often decreases the disk efficiency is non-optimal allocation 
of files, the so-called file fragmentation. Under some inevitable circumstances the system keeps fragments of a file in different 
places of the disk, what significantly slows down reading operations. To de-fragment files, it is sometimes necessary to re-write 
them more compactly. It resembles threading beads – file fragments are gathering one by one, after that the system will spend less 
time on reading the file.  
 
There are many solutions for the file fragmentation problem. Total Defrag is one of them. It is a reliable tool, which provides 27 
defragmentation strategies and uses unique low-level optimization algorithms (see the complete list of key features). Despite the 
complicity of tasks Total Defrag has an easy-to-use interface. Moreover the present manual will help you to find the answers to 
many of the technical questions, which might arise while using the program. 

2 Key Features  
Let us list some of the key features:  
 

 User-friendly interface. Easily understood icons accompany all functions of the program. 
 27 different defragmentation strategies for optimal speed increase. A properly chosen strategy allows setting the 

procedure in full accordance with the user needs. Your choice might depend on size of using files, a number of 
directories and a frequency of file updates.   

 Unique low-level file system defragmentation and optimization algorithms, which gives the ability to operate disks of 
different file systems. 

 Defragmentation of the Master File Table (MFT) and system metadata, which usually are not available for standard 
system utilities (although their optimization increases the file system performance). 

 Defragmentation of files that are located on USB 2.0 and IEEE 1394 (Fire Wire) drives (fixed drives only, not removable 
ones).  

 Low free space defragmentation (less 1% free space required), what lets you defragment almost full disks. 
 Detailed file fragmentation statistics on any of partitions. The user can analyze the file allocation with a map where a file 

structure is represented in a bright graphical form.   
 Exhaustive reports about every defragmentation procedure with the ability to save it on a disk for the further analysis. 
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3 Installation  
This chapter provides information, which is needed to perform the correct installation of the program, and in addition, checks if 
the current installation is working correctly.  

3.1 Minimum System Requirements  
To use the program on a computer satisfactorily, ensure that it meets the following minimum system requirements: 

 Operating systems: Windows 2000/XP/2003/Vista   
 Internet Explorer 5.0 or higher  
 Intel Pentium CPU or its equivalent, with 300 MHz processor clock speed 
 128 MB of RAM required (256 MB or more recommended) 
 Hard disk drive with 20 MB of available space 
 Supports USB 2.0 and IEEE 1394 (Fire Wire) drives 

3.2 Installation Procedure 
The installation process consists of the following steps: 
 
1. Run Setup Application 
From the folder, where the setup files are kept, run the SETUP.EXE file. This application will guide the user through the process 
of the program installation. The setup utility is compiled with the InstallShield SDK, hence it contains the standard user interface 
and set of installation steps. 
 
2. Starting Setup 
The Welcome page informs that the application is being installed. Click the Next button to continue. 
 
3. Confirm License Agreement 
The License Agreement page displays the Paragon License Agreement. Read the agreement and then click the Yes button to 
accept. If the user does not agree with any conditions stated there, the installation process will be interrupted. 
 
4. Select an Installation Folder 
The Destination Location page allows the user to choose the folder where the program will be installed. By default, the installation 
folder will be created as: 
 
C:\Program Files\Paragon Software\Paragon Total Defrag 2007. To select another folder, click the Browse button. 
 
After you have selected the required folder, click the Next button to continue. 
 
5. Select a Program Group 
 
The Program Folder page enables the user to select the application's program group for the Start Menu. By default, it will be the 
program group: 
 
Start > Programs > Paragon Total Defrag 2007. 
 
Click the Next button to continue. 
 
6. Verify Setup Settings 
 
The Start Copying page allows the user to verify settings, which have already been made and correct them if necessary. Press the 
Back button to return to the previous page and modify the installation settings. Click the Next button to complete the installation 
process. 
 
7. Copying Files 
 
The Setup Status page shows the overall progress of the installation. Click the Cancel button to abort the setup. 

Copyright© 1994-2007 Paragon Software Group. All rights reserved. 
 



Total Defrag 2007 5 User Manual 

 
8. Finishing the Installation 
 
The Final page reports the end of the setup process. Components included in the package are ready to use immediately after 
completing the installation process. 
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4 Basic Concepts  
This chapter explains terms and ideas that show how the program works. To understand these helps to obtain a general notion of 
the operation performance and makes it easier for the user to operate the program. 

4.1 A Hard Disk Layout 
Before optimizing any system we need to understand it. Speaking about a file system of your computer we should picture how 
files are stored on a hard disk.  
In appearance a hard disk resembles a set of mirror-smooth CD/DVDs or platters (they are even called the same). Every disk 
platter is divided to tracks and sectors. Tracks are concentric circles. Sectors are radial wedges. Mentioning a track and a sector we 
can easily find any place on the disk: 
 

 
 
Sectors have a fixed size and contain a certain number of bytes (512, for example), which depends on an operating system.  
 
As in the case of platters a computer starts reading (or writing) information from external tracks. The main reason for that is the 
next – a hard disk works faster on these tracks (having a permanent angular velocity we have the maximal linear velocity exactly 
on the external tracks). Please pay your attention on this important fact. If you keep data recorded in the beginning of the disk, it 
will be found and operated faster than data kept on the internal tracks. 
 

 
 
Dividing the disk to tracks and sectors are named low-level formatting. However before we are able to place our files on the disk 
we should create special high-level structures, which help to organize our records and to manage them. Similar structures form a 
file system. When we are performing high-level formatting, we are creating such structures as a file allocation table (FAT), data 
blocks (where our future files can be stored) and some others.  

4.2 File Fragmentation  

Copyright© 1994-2007 Paragon Software Group. All rights reserved. 
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the other parts (fragments) of the file are stored. In the case of fragmented files the system has to search the hard disk every time 
the file is opened to find all of its fragments what noticeably slows down the response time.  
 

 
 
Service files of operating systems may be also fragmented. The NTFS file system has for example a special file, the Master File 
Table (MFT), which is a well-organized catalogue of all files on a partition. The table keeps records about every file allocation, 
about its attributes and even contents of small size files. MFT is a system file, which is stored on a protected part of the NTFS 
partition (the so-called MFT zone). Usually the $MFT file is inaccessible for standard defragmentation tools (not for Total 
Defrag!) although it is subject to fragmentation as any other file.  

4.3 De-fragmentation  
The medicine against the fragmentation is evident. We should rewrite different parts of any file to contiguous sectors on the hard 
disk. This process is called de-fragmentation. It often helps to increase the speed of file access and data retrieval. 
 

 
 
Total Defrag enables to re-write files in an optimal way depending on peculiarities of the file system and on your tasks. So it 
allows taking into account the following conditions: 

 If you work with big size files (multimedia or CAD files are usually big), then it is reasonable to place them into those 
sectors of the disk where your computer could operate them faster, i.e. to the first sectors of the disk. It might be done 
during the defragmentation procedure (see the Defragmenting a Partition chapter).   

 If a hard disk has a great number of directories (for example it may be a data base or your favorite music collection), then 
you should also place directories on the sectors with the highest disk performance to make search files faster. 

 And at least placing most frequently updating files to the first sectors of the disk will provide the performance increase 
too.     

Before starting the defragmentation procedure we also recommend to draw your attention to PAGEFILE.SYS and 
HIBERFIL.SYS system files that are used in the NTFS system as the temporary ones. They are re-initialized at the beginning of 
every Windows session and they are absolutely unimportant between the sessions. Excluding them from the processing files you 
save time. 
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5 Interface Overview  
This chapter introduces the graphical interface of the program. The design of the interface precludes any mistake being made on 
the part of the user. Buttons and menus are accompanied by easy understandable icons. Nevertheless, any problems that might 
occur while managing the program can be tackled by reading this very chapter. 

5.1 General Layout  
When the user starts the program, the first component that is displayed is called the Launcher. It enables the user to run wizards 
and utilities, to specify program settings, to visualize the operating environment and the hard disk configuration. 

The Launcher’s window can be conditionally subdivided into several sections that differ in their purpose and functionality: 

1. Main Menu  
2. Tool Bar  
3. Defragment Operations Bar  
4. Common Tasks Bar  
5. Explorer Bar  
6. Defragment Map 
7. Disk Map  
8. Disk Map Legend 
9. Status Bar  
 
Some of the panels have similar functionality with a synchronized layout. The program enables the user to conceal some of the 
panels to simplify the interface management. 
 
All panels are separated by vertical and horizontal expandable sliders, allowing the user to customize the screen layout. 

5.2 Main Menu  
The Main Menu provides access to the entire functionality of the program. The available functions are as listed below: 

MENU ITEM  FUNCTIONALITY  
Tools     
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Settings  Edit the general settings of the program  
Exit  Exit the program  
Changes  
Reload Disk Info  Refresh the current information about disks  
Hard Disk    
Properties Display the hard disk properties 
Partition    
Shrink MFT Perform the MFT shrinking procedure for a chosen NTFS partition 
Analyze Defragment Display the structure of partition blocks in the form of the Defragmentation map 
Defragment Partition…  Perform the defragmentation process for a chosen partition 
Defragment MFT… Perform the defragmentation of the MFT file (for a NTFS partition) 
Cancel Cancel the running defragmentation procedure 
Test surface… Perform the surface test for a chosen partition 
Check File System 
Integrity Perform the integrity test for a chosen partition 

Properties Display the hard disk properties 
View     
Toolbar  Manage the Tool bar representation: show / hide standard buttons, text labels and large icons.  
Status Bar  Display the Status bar  
Common Tasks Bar  Display the Common tasks bar  
Disk Map Legend Display the Disk map legend 
Defragmentation Map Display the Defragmentation Map 
Disk Map Location  Select whether the Disk map will be located on the top of the main window or at the bottom  
Help     
Help  Open the Help system  
About  Open the dialog with information about the program  
  

5.3 Tool Bar  
The Toolbar provides fast access to the most frequently used operations: 

BUTTON  FUNCTIONALITY  

 
Perform the integrity test for a file system  

 
Perform shrinking MFT for a NTFS partition

 
Open the Help system 

5.4 Defragment Operations Bar  
The Defragment Operation Bar enables to manage the defragmentation procedure. 
 
BUTTON  FUNCTIONALITY  

Copyright© 1994-2007 Paragon Software Group. All rights reserved. 
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Analyze the fragmentation. The program displays 
the current structure of partition blocks in the 
form of the Defragmentation map.   

 
Start the defragmentation procedure for a disk / a 
partition.  

 
Start the MFT defragmentation procedure for a 
NTFS partition. 

 
Cancel the running defragmentation procedure 

5.5 Common Tasks Bar  
The Common Tasks Bar is located on the left side of the main window. It is intended for easy access to News, Help System, Web 
References and other documentation. 

The bar contains a tab called News and Documentation, which can be folded by clicking it. 

News and Documentation  

 

Opening the page, which contains information about the program. 
This page will be displayed in the Explorer bar. 

 
Launching the Help system. 

5.6 Disk Map  
The Disk Map is displayed in the Explorer bar when the Disk View tab is selected. It is located either at the top or at the bottom of 
the window, depending on the state of the Disk Map Location option (Main menu: View > Disk Map Location). The user can 
change the current location of the map with this option. 
 
As the name infers, the Disk Map displays the layout of physical and logical disks. Physical disks are represented with rectangle 
bars that contain small-sized bars. These small-sized bars represent logical disks. Their color depends on the file system of the 
appropriate partition. 
 

 
 
Large-sized bars display the following information about physical disks: 

 Manufacturer, 
 Model. 

 
Small-sized bars display the following information about logical disks: 

 Serial number, 
 Drive letter, 
 Total size, 
 File system. 

 
Furthermore, it is possible to estimate the used disk space by looking at the size of the bar’s shaded area. 
 
Disk Map is synchronized with the Explorer bar and the Defragment Map. When the user selects a disk on the Disk Map the 
Explorer bar and the Defragment Map display detailed information of the selected disk. 
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Total Defrag 2007 11 User Manual 

 

 
The user can click a large-sized bar to display information about the appropriate physical disk in the Explorer 
bar. A click on a small-sized bar will lead to displaying information about the appropriate logical disk. 

5.7 Legend Bar 
The Legend Bar explains the color scheme used for disk and partition presentation. The user can hide (or show) the bar with the 
appropriate Main menu item: View > Disk Map Legend. When it is activated it can be found at the bottom of the Explorer bar.  
 
The program distinguishes between the following types of known file systems: 
 
   - FAT16/32,  
   - NTFS, 

- Linux Ext2/3,  
- Linux ReiserFS. 

5.8 Explorer Bar 
The Explorer Bar is located in the center of the main window, which emphasizes its importance. The bar displays reference 
information including: 
 

 User Manual, 
 Information about the program consisting of the product's name, the version of the program and a list of helpful links, 
 Detailed information about disks selected on the Disk Map, 
 Defragment Map. 

 
According to these categories the Explorer bar has four tabs: 
 

 Disk View, which allows the user to view detailed information about any of the disks. 
 Help System, which contains the User Manual and information about the program. 

 
The user is able to access the desired information by clicking on the appropriate tab. 
 
The Explorer Bar is a fully-functional embedded HTML browser, which enables the user to address, for example, our company's 
website to look through important technical notes or download the latest updates without having to close the program. The Help 
System of the program is HTML-oriented. The user can read the user manual and follow external links from to get additional 
information. 
 

 
 
To easily navigate through browsed pages, the program provides the following functionality: 
 
BUTTON FUNCTIONALITY  

 Return to the previously browsed page  

 Open the next browsed page  
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 Stop loading the current page  

 Refresh the contents of the current page  

5.9 Defragment Map 
Defragment Map is another helpful tool that enables the user to get a clear-cut picture of the current state of the file system. The 
map represents the structure of blocks for a partition, which has been selected in the Disk Map. The disk name will be displayed at 
the top part of the bar. Below the disk name the user sees the Defragment Map itself. Block colors depend on their types. The 
correspondence between a color and a block type is in the map legend.  
 

 
 
When the user starts the defragmentation procedure, there is the ability to see how the program re-writes file fragments more 
compactly and disk blocks change their colors from red to green.      
 
Furthermore, the Defragment Map is synchronized with the Explorer bar and the Disk Map. 

5.10 Status Bar  
This is the bottom part of the main window. The status bar displays menu hints, for each item the cursor points to. 
 
The user can hide (or show) the bar with the appropriate Main menu item: View > Status bar. 

6 Settings Overview 
The Settings dialog is available from the Main menu: Tools > Settings. All the settings are grouped into several sections of which 
the functions are described in the following paragraphs. The list of sections is placed on the left side of the dialog. By selecting a 
section from the list, the user opens a set of options. 

6.1 General Options  
This section contains a set of general options that will be taken into account during all the operations carried out with the program. 
The user can switch between the following modes: 

 Verify data written. If this option is marked, every write-to-disk action is followed by the read-and-compare 
action. This feature may be helpful in case of running an unstable hard disk, however it will negatively affect the 
overall performance. 

 Enable data loss protection. Activate the option to force the program to work in the fail-safe mode (also 
referred to as data-loss protection mode), which ensures more safety for operations by maintaining the special 
journal of operations’ progress. In case of hardware malfunction, power outages or operating system failure, the 
modified partition may become corrupted and non-operable. However, the program will be able to complete the 
interrupted operation, thus "reviving" the partition. 

 
If the system has crashed during the operation in the fail-safe mode, insert the bootable Recovery CD and restart 
the computer. The program will automatically detect the journal of the interrupted operation and complete the 
operation. 
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 Try to access non-BIOS disk cylinders. The option works only under Windows 95, 98, ME. When activated, 
the program performs a special procedure to define the disk capacity and does not use the value that is returned 
by BIOS. 

 

 

6.2 E-Mail Options 
This section contains a set of options that will be taken into account during the Send log files and Send e-mail notification 
operations. The user can define: 
 

 Outgoing mail server (SMTP). To send messages by using the built-in mail client, it is necessary to have access to a 
computer running an SMTP (Simple Mail Transfer Protocol) server. All outgoing messages are first sent to the SMTP 
server, which in its turn delivers them to the required recipients. The address may be represented as a traditional Internet 
host name (e.g.: mail.com) or as an IP numeric address (e.g. xxx.xxx.xxx.xx). 

 User e-mail address. Specify an e-mail address that has been assigned by the Internet Service Provider or organization's 
e-mail administrator. 

 My outgoing server requires authentication. Activate the option to allow the program to make authentication on the 
server before sending messages. 
- User name. Enter the name that will be used to log in to the e-mail account. 
- Password. Enter the password that will be used to access the mail server. 

 
 Send e-mail notification on apply. Specify an e-mail to send notifications on the carried out operations.  

- Send mail in HTML format. Activate the option to create messages in the HTML format instead of plain text. 
- Send complete report after applying operations. Activate the option to create an in-depth report on the carried out 
operations and send it after performing the last operation. 
- Send graphical view of the disk sub-system before and after apply. Activate the option to allow the program to 
attach two pictures of the disk layout made before and after the operation is completed. 
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6.3 Operation Dependency Options 
This section contains a set of options that will be taken into account when the Send e-mail notification on apply function is 
enabled. By marking the appropriate operations the user can choose whether to receive an e-mail notification after the particular 
operation is completed or not. Some of the listed operations can be related to other Paragon products, which are also installed in 
the system.  
 
However the user will not be notified by e-mail in case operations (if any) require the system reboot.  
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7 How to Optimize a File System  
This chapter lists various scenarios of disk system optimization, which might be accomplished by the program. This has already 
been reviewed in the Basic concepts chapter. Here the user will find more useful recommendations and descriptions of operations.  

7.1 Analyzing Disks   
To begin with, let us examine the current situation of the available disk space. The program provides some helpful tools for this 
purpose.  
 

7.1.1 Analyzing File Fragmentation 

The program allows analyzing the fragmentation of any partition that has been selected in the Disk Map. For a preliminary 
estimate the Defragment Map can be used. It represents the current structure of partition blocks in the graphic form.  
 

 
 
Blocks are colored in accordance with their types – free, fragmented, writing, reading, used and blocks of unsupported file 
systems. Fragmented blocks are well noticeable – they’re red. The more red-marked blocks the greater extent of the 
fragmentation. If fragmented blocks content more than 50 per cent, it is reasonable to accomplish the defragmentation procedure.  
 
To get more exact information, the user should take the following steps:    
 
1. Select a partition on the Disk Map.  
 
2. Start the special analyzing procedure. There are several ways to do it: 
 

 Select in the Main menu: Partition > Defragment > Analyze Defragment 
 Click the Analyze button in the Defragment Operation Bar. 

 
Results of the analysis will be displayed in a new dialog.  
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They include the exact value of the fragmentation (in per cent) and the detailed information about fragmented files. To get the last, 
just click the button Show Files Fragmentation Details. The information contains:  
 

 A number of file fragments  
 Size of fragments 
 Names of fragmented files.  

 
To close this part of the dialog, click the Hide Files Fragmentation Details. There is also the possibility to save analysis reports 
into a file on the disk.  
 
If the user sees that the fragmentation level is too high, one can start the de-fragmentation procedure by clicking the corresponding 
button at the foot of the map.   

7.1.2 Viewing Disk Properties  

The user enables to view in-depth information on the properties of hard disks. The main tools to extract this information are the 
Disk Map and the Defragment Map. The both maps represent the actual state of the computer’s hard disks. 
 
Generally the hard disks are represented on the Disk map by rectangular bars, which also contain small-sized bars. The small-
sized bars represent logical disks (partitions). When the user selects a large-sized bar, the Explorer bar displays information about 
the disk in a bright, graphical form.  
 

 
 
The model and serial number of the disk serve as the title of the browsed page. The disk layout is shown in form of a circular 
graph, where the color of a sector corresponds to a file system of an appropriate partition. On the right the user may see a table, 
which contains the following information: 
 

 Type of hard disk (basic or dynamic), 
 Total size (in GB), 
 Information on geometry of the disk (amount of sectors per track, heads and cylinders). 
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When the user selects a small-sized bar (i.e. corresponding to a logical disk), additionally to standard information about the 
partition the Explorer will display the state of partition blocks on the Defragment Map what allows the user to estimate file 
fragmentation. The standard information about the partition will contain the following: 
 

 Volume label (if available), 
 Type of the logical disk, 
 File system (represented by the color of the graph and the selected bar), 
 Total size, used space and free space (in GB or MB). 

 

7.1.3 Viewing Partition/Hard Disk Properties 

The program enables to obtain in-depth information on the properties of hard disks/partitions. Besides the general information, 
such as capacity, used space or file system type it provides the possibility to get info on a hard disk geometry, cluster size, exact 
partition location, etc. 
 
In order to view properties of a partition/hard disk the user should take the following steps: 
 
1. Select a partition/hard disk on the Disk Map. 
 
2. Call the Properties dialog. There are several ways to do it: 
 

 Select in the Main menu: Partition/Hard Disk > Properties… 
 Call the popup menu for the selected partition/hard disk (right click of the mouse button) on the Disk Map, then select the 

menu item: Properties… 
 

 
 
3. The provided information is grouped according to its properties, thus select the required tab and get the information you need. 

7.1.4 Testing Disk Surface 
Copyright© 1994-2007 Paragon Software Group. All rights reserved. 
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The disk analysis may also include surface tests. The program allows performing these tests on existing partitions.  
 
In order to start the surface test the user should take the following steps: 
 
1. Select a partition on the Disk Map.  
 
2. Call the Test Surface dialog to define appropriate settings. There are several ways to do it: 
 

 Select in the Main menu: Partition > Test Surface… 
 Call the popup menu for the selected partition (right click of the mouse button) on the Disk Map, then select the menu 

item: Test Surface… 
 

 
 
Surface test level. Choose the level of the test procedure. 
 
3. The operation will be performed immediately after confirmation. 

7.1.5 Checking a File System Integrity 

The program enables to check the file system integrity on existing partitions. This function can be used for detecting file system 
errors before performing operations on a partition. Some operations (such as the defragmentation) require the targeted partition to 
have a valid file system to be processed. 
 
In order to start the system integrity check the user should take the following steps: 
 
1. Select a partition on the Disk Map.  
 
2. Call the Check File System Integrity dialog to define appropriate settings. There are several ways to do it: 
 

 Select in the Main menu: Partition > Check File System Integrity. 
 Click the Check File System Integrity button in the Toolbar. 
 Call the popup menu for the selected partition (right click of the mouse button) on the Disk Map, then select the menu 

item: Check File System Integrity. 
 

 
 
3. The operation will be performed immediately after confirmation. 

7.2 Defragmenting a Partition 
Defragmentation is the process of rewriting different parts of a file (its fragments) to contiguous sectors of a hard disk to increase 
the speed of file access and retrieval (see the Basic concepts chapter for more details).  
 
The program provides a necessary tool for the defragmentation of NTFS and FAT partitions of a hard disk.  
 

 
The user must have administrator’s privileges to accomplish the defragmentation of the system partition 
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In order to start the operation the user should take the following steps: 
 
1. Select a partition on the Disk Map.  
 
2. Call the Defragment Partition dialog to define appropriate settings. There are several ways to do it: 
 

 Select in the Main menu: Partition > Defragment > Defragment Partition… 
 Click the Defragment Partition button in the Defragment Operation Bar. 
 Click the Defragment button, which will be available at the foot of the Defragmentation Analysis Report  after the 

analyzing procedure.      
 Call the popup menu for the selected partition (right click of the mouse button) on the Disk Map, then select the menu 

item: Defragment Partition… 
 
3. Define parameters of the operation with the Defragment Partition dialog. Initially the program suggests some consistent values 
for all parameters. In most cases, the user may just press the OK button to confirm the operation. At the same time there is the 
possibility to set the procedure in full accordance to peculiarities of the current file structure. So you can consider the following 
details:  
 

 
 

 Directories Placement. From the pull-down list select where to place directories during the defragmentation procedure. 
They should be putted first, if you have a great number of them on the partition. In this case directories will be placed in 
sectors with the highest speed of access what decreases file search time.  

 Sort by size. Sort files according to their size. This option enables to place large files first, i.e. in sectors where the disk 
performance is maximal. If you work with large files (such as multimedia or CAD ones), it will speed up read/write 
operations for these files.   

 Sort by time. Sort files according to the last time of update. It helps you to put most frequently updating files to the 
starting sectors of the disk what will lead to increasing response time for them.  

 Skip auxiliary files. Mark the option to ignore contents of the PAGEFILE.SYS and HIBERFIL.SYS system files. These 
files are used temporarily in the operating system. 
You are able to get more information about available strategies of the defragmentation in the Basic concepts chapter. 

 
4. The operation will be performed immediately after your confirmation. During all the procedure you are able to control the 
current state of the partition with the Defragment map. This map reflects a level of the fragmentation. Disk blocks are colored in 
accordance with their types – free, fragmented, used and blocks of unsupported file systems. Fragmented blocks are well 
noticeable – they’re red. The more red-marked blocks the greater extent of the fragmentation.    
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The More information button gives the ability to watch the defragmentation progress, to estimate the time left till the operation 
completion. In this mode the option “Shutdown system on complete” is available. To close this additional panel, the user should 
click the Fewer information button. 
 

 
 

 

Sometimes the defragmentation procedure requires rebooting the computer. The program has to have exclusive 
access to the processing partition. Especially this is right for the system partition where background read/write 
operations are frequently performed.   

 
The running operation can be stopped by clicking the Cancel button in the Defragment Operations Bar. 
 
5. After completing the operation, the user will get the exhaustive report about the defragmentation. There is the possibility to 
save it on a disk.  

7.3 Defragmenting the MFT  
The MFT (Master File Table) is an NTFS system file that contains in-depth information on files, including size, time and date 
stamps, permissions, and data contents. In the course of time the MFT file can also be fragmented, thus slowing down the speed at 
which data is accessed (see the Basic concepts chapter for more details). 
 
The program offers its users a special tool to defragment the MFT file. 
 

 
The user must have administrator’s privileges to accomplish the defragmentation of the MFT file. 

 
In order to start the operation the user should take the following steps: 
 
1. Select an NTFS partition on the Disk Map.  
 
2. Call the Defragment MFT dialog to define appropriate settings. There are several ways to do it: 
 

 Select in the Main menu: Partition > Defragment > Defragment MFT… 
 Call the popup menu for the selected partition (right click of the mouse button) on the Disk Map, then select the menu 

item: Defragment MFT… 
 

 
 
3. The operation will be performed immediately after confirmation. 

7.4 Shrinking the MFT  
There is the ability to re-write MFT (Master File Table) in a more compact way what will also increase access speed for files of 
NTFS partitions.  
 

 
The user must have administrator’s privileges to accomplish this operation with the MFT file. 
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1. Select an NTFS partition on the Disk Map.  
 
2. Call the Shrinking MFT dialog to define appropriate settings. There are several ways to do it: 
 

 Select in the Main menu: Partition > Modify > Shrink MFT… 
 Call the popup menu for the selected partition (right click of the mouse button) on the Disk Map, then select the menu 

item: Shrink MFT… 
 
3. Define parameters of the operation with the Shrink MFT dialog. Initially the program suggests some consistent values for all 
parameters 
 

 
 

 Compact records. In this case the program will re-write MFT records moving them to the table head.  
 Truncate MFT after compacting. Emptied during the procedure the table rows will be removed  

 
4. The operation will be performed immediately after confirmation. 
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